Gaming on Fedora + NVIDIA = Not Working

Hello y’all.

Just arrived on Fedora :grinning:
Using version 32 here

Moved from Ubuntu and Ubuntu based to Debian, but it’s too hard to install the NVIDIA driver on Debian for systems that have onboard AND offboard GPUs.
So here I am, using Fedora with an apparently installed driver that does not work :man_facepalming:

This is part of the lspci -v

01:00.0 VGA compatible controller: NVIDIA Corporation TU117M [GeForce GTX 1650 Mobile / Max-Q] (rev a1) (prog-if 00 [VGA controller])
Subsystem: Dell Device 0949
Flags: bus master, fast devsel, latency 0, IRQ 140
Memory at a2000000 (32-bit, non-prefetchable) [size=16M]
Memory at 90000000 (64-bit, prefetchable) [size=256M]
Memory at a0000000 (64-bit, prefetchable) [size=32M]
I/O ports at 4000 [size=128]
Expansion ROM at a3000000 [virtual] [disabled] [size=512K]
Capabilities: <access denied>
Kernel driver in use: nvidia
Kernel modules: nouveau, nvidia_drm, nvidia

Whenever I run CS:GO or Dota 2, I get poor graphics.

Can anybody please help me get the NVIDIA GPU working properly, please?

Hi @Yandiro and welcome to the community. When you have some time, please take a look at the #start-here category, which contains useful info on using the forum’s features.

I don’t have any NVidia cards, so cannot help you directly, but firstly, have you tried the open source driver (nouveau)? If that is sufficient for your needs, it generally causes much fewer problems. Secondly, have you seen the thread about this tool:

That might help with issues related to the driver.

3 Likes

install NVIDIA driver in linux (debian as well as fedora ) is a little painful process,if you wand you can try pop os which have NVIDIA driver already installed and configured

2 Likes

Pop!_OS is commendable for their efforts of having NVIDIA drivers installed from get-go. Though the following are the stuff that you should be aware about before you make a jump.

  1. Pop!_OS has excruciatingly high screen tearing problem with the bundled NVIDIA driver. The bundled one is the only one you are so there is literally no way around it.
  2. Pop!_OS uses the X11 session which is currently the defacto “render-with-my-discrete-GPU” session but there are random artifacting issues with all of GNOME widgets.
  3. The driver shipped to Pop!_OS is almost one minor release behind. You can put that rigorous testing thing in the mix but it isn’t really so unstable that releases are slowed.
  4. Fedora has the better performance (though right after Arch Linux) than Ubuntu when it comes to OpenGL and Vulkan rendering pipelines across the board.
  5. The driver packages from RPM Fusion are really low-level. By low-level, I mean that the proprietary NVIDIA drivers are simply repackaged to RPM scheme with no changes.

Would you really want to make the jump?

2 Likes

Your configuration looks a simple “non-optimus” one to me. Installing drivers here should be a breeze. Check the following links out.

  1. NVIDIA Auto Installer for Fedora - Find the binaries in the releases section.
  2. RPM Fusion’s NVIDIA How-to guide

I just uninstalled Pop OS, hahaha. Yeah, that is a good point for POP OS, but I feel all the Ubuntu based distros a little laggy.

Also gave a try on Manjaro, cuz it also installs the driver from OS installation, but I got the ‘dummy output’ problem and just decided to move to Fedora because I think it works more similarly to Debian than Manjaro. (apt and dnf)

1 Like

I did install the driver using RPM Fusion. But it’s not working =(

This is what I got using that tool:

[ :heavy_check_mark: ] GATHERING ACTIVE INFORMATION…
[ :heavy_check_mark: ] Host information was gathered!
System: Linux
Hostname: localhost.localdomain
Release: 5.7.8-200.fc32.x86_64
Version: #1 SMP Thu Jul 9 14:34:51 UTC 2020
Machine: x86_64
[ :heavy_check_mark: ] CHECKING FOR GPU COMPATIBILITY…
[ :heavy_check_mark: ] Compatibility infomation was obtained!
00:02.0 VGA compatible controller: Intel Corporation UHD Graphics 630 (Mobile)
01:00.0 VGA compatible controller: NVIDIA Corporation TU117M [GeForce GTX 1650 Mobile / Max-Q] (rev a1)
[ :heavy_check_mark: ] An active NVIDIA GPU was detected!
[ :heavy_check_mark: ] An Optimus Dual GPU setup was detected!
[ :heavy_check_mark: ] LOOKING FOR EXISTING PACKAGES…
[ :heavy_check_mark: ] A total of 8 driver packages were detected!
akmod-nvidia-440.100-1.fc32.x86_64
xorg-x11-drv-nvidia-libs-440.100-1.fc32.i686
xorg-x11-drv-nvidia-kmodsrc-440.100-1.fc32.x86_64
xorg-x11-drv-nvidia-cuda-libs-440.100-1.fc32.x86_64
xorg-x11-drv-nvidia-libs-440.100-1.fc32.x86_64
kmod-nvidia-5.7.8-200.fc32.x86_64-440.100-1.fc32.x86_64
nvidia-settings-440.100-1.fc32.x86_64
xorg-x11-drv-nvidia-440.100-1.fc32.x86_64
[ ! ] Do you wish to reinstall the drivers? (Y/N)

After I press Y and RETURN, I get this:

[ :heavy_check_mark: ] ATTEMPTING CONNECTION TO RPMFUSION…
[ :heavy_check_mark: ] Connection to RPMFusion server was established!
[ ! ] RPMFusion repository for Proprietary NVIDIA Driver not detected!
[ ! ] Do you wish to fetch packages from this repository? (Y/N) y
[ :heavy_check_mark: ] FETCHING REPOSITORY DATA…
[ ✘ ] RPMFusion NVIDIA repository could not be enabled!
[ ✘ ] Leaving installer

So apparently it is installed, but does not work. EFI Secure boot is disabled.
Should I configure it or it is an install-and-play?

did you try fedy {software store}

The installer is not able to connect to the repository. Are you sure you are connected to the internet on that machine?

1 Like

Also, please send the outputs of sudo ./NVAutoInstFedora32 --cheksu and sudo ./NVAutoInstFedora32 --compat please. It would help me figure out what exactly the problem might be.

1 Like

Also, you seem to have installed the driver already. Why are you trying to install them again? Plus if you have installed - did you pick the negativo repo or the RPM Fusion one?

1 Like

If I run steam with this command:
__NV_PRIME_RENDER_OFFLOAD=1 __GLX_VENDOR_LIBRARY_NAME=nvidia steam

the graphics card woks fine.

Is there an auto way to use the external GPU?

@t0xic0der, so it seems it was the sudo problem. After running with sudo, the installer works, however, the driver is already installed.

[ # ] NVIDIA AUTOINSTALLER FOR FEDORA 32 AND ABOVE
[ # ] CHECKING SUPERUSER PERMISSIONS...
[ ✔ ] Superuser privilege acquired
[ # ] CHECKING AVAILABILITY OF RPM FUSION NVIDIA REPOSITORY...
[ ! ] RPM Fusion repository for Proprietary NVIDIA Driver was detected
[ # ] ATTEMPTING CONNECTION TO RPM FUSION SERVERS...
[ ✔ ] Connection to RPM Fusion servers was established
[ # ] LOOKING FOR EXISTING DRIVER PACKAGES...
      kmod-nvidia-5.7.9-200.fc32.x86_64-440.100-1.fc32.x86_64
      akmod-nvidia-440.100-1.fc32.x86_64
      xorg-x11-drv-nvidia-libs-440.100-1.fc32.i686
      xorg-x11-drv-nvidia-kmodsrc-440.100-1.fc32.x86_64
      xorg-x11-drv-nvidia-cuda-libs-440.100-1.fc32.x86_64
      xorg-x11-drv-nvidia-libs-440.100-1.fc32.x86_64
      kmod-nvidia-5.7.8-200.fc32.x86_64-440.100-1.fc32.x86_64
      nvidia-settings-440.100-1.fc32.x86_64
      xorg-x11-drv-nvidia-440.100-1.fc32.x86_64
[ ! ] A total of 9 driver packages were detected
[ # ] REINSTALLING PROPRIETARY DRIVERS...
RPM Fusion for Fedora 32 - Nonfree - NVIDIA Driver                                                                                                                                                           4.6 kB/s | 8.3 kB     00:01    
Package gcc-10.1.1-1.fc32.x86_64 is already installed.
Package kernel-headers-5.7.7-200.fc32.x86_64 is already installed.
Package kernel-devel-5.7.8-200.fc32.x86_64 is already installed.
Package kernel-devel-5.7.9-200.fc32.x86_64 is already installed.
Package akmod-nvidia-3:440.100-1.fc32.x86_64 is already installed.
Package xorg-x11-drv-nvidia-3:440.100-1.fc32.x86_64 is already installed.
Package xorg-x11-drv-nvidia-libs-3:440.100-1.fc32.x86_64 is already installed.
Package xorg-x11-drv-nvidia-libs-3:440.100-1.fc32.i686 is already installed.
Dependencies resolved.
Nothing to do.
Complete!

I just can’t get it to work automatically. I have to run STEAM with this command: __NV_PRIME_RENDER_OFFLOAD=1 __GLX_VENDOR_LIBRARY_NAME=nvidia steam

How can I get it to work seamlessly??

Glad to know it worked for you. The drivers are already installed because you mentioned you had followed the RPM Fusion’s NVIDIA How-to guide for installing them.

As the name speaks for it, the application I wrote is simply for installing the drivers and not configuring them for finer specifications like those of Optimus-based devices. Yours is supposedly not an Optimus-based device so it should work without putting much effort.

Can you send me a screenshot of nvidia-xconfig's status page? It would give me the percentage of GPU utility which can be used to figure out how much of the GPU is utilized (that is, if at all it is utilized)

If you are using the Workstation, you can simply right-click on the shortcut of the application that you would want to run using the discrete GPU and click on “Run with dedicated graphics card”.

If you are using the Workstation, you can simply right-click on the shortcut of the application that you would want to run using the discrete GPU and click on “Run with dedicated graphics card”.
I can’t see that option when I right-click on softwares inside the ‘start menu’.

So what I did was to set for each game the launch option:
__NV_PRIME_RENDER_OFFLOAD=1 __GLX_VENDOR_LIBRARY_NAME=nvidia %command%

For CS:GO, the -fullscreen option goes after this all, for example.

This way I don’t need to worry about launching STEAM itself. I was playing with an open window of terminal.
Hope this helps anybody else.