Gcl/readline error when upgrading to Fedora 30 using dnf

I’m seeing this on the upgrade attempt:

        Error: 
         Problem: problem with installed package gcl-2.6.12-12.fc29.x86_64
          - package gcl-2.6.12-12.fc29.x86_64 requires libreadline.so.7()(64bit), but none of the providers can be installed
          - readline-7.0-12.fc29.x86_64 does not belong to a distupgrade repository

And the upgrade hangs for about 15-20 minutes at:

    `Total                                                                                                                                                                              
     
        34 MB/s | 4.4 GB     02:clock11: Running transaction check
        Transaction check succeeded.
        Running transaction test
        Transaction test succeeded.
        Running transaction
          Preparing        :

Please uninstall gcl to upgrade. Unfortunately, the gcl package is quite complex and has not been built for Fedora 30 yet. The maintainer is working on it:

https://koji.fedoraproject.org/koji/packageinfo?packageID=1820

You can follow progress by cc’ing yourself to this bug:

https://bugzilla.redhat.com/show_bug.cgi?id=1674924

Since using dnf would remove dnf, I ran rpm -e --nodeps gcl-2.6.12-12.fc29.x86_64

Anything to do about readline?

Oh? Really?

Well the idea is to remove the least number of packages that let the upgrade through. Is it getting stuck on readline too?

No this time it worked without any dependencies but now I’m stuck at a dracut shell:

The UUID for a device is not being seen. Any suggestions?