Gdm won't start after the latest (3-Jul-2020) update of Fedora 32

I’ve been using Fedora 32 Workstation on a VMware virtual machine.
After the latest update on 3-Jul-2020, gnome display manager won’t start.

$ sudo dnf update -y && sudo shutdown -r now
resulted in black screen.

By ssh from a remote console, I’ve confirmed that the system itself has started and by
$ sudo systemctl isolate multi-user.target
from the remote console, the display shows login prompt and I can login.

However,
$ sudo systemctl isolate graphical.target
falls back into the black screen again.

I think I should look for error massages by journalctl but I don’t know well how to find them. I’m wondering if anyone would tell me how to do it using journalctl.

2 Likes

This is the first thing I would check:

systemctl status --full gdm.service

You can look for errors in journalctl with:

sudo journalctl -p err

If your journal is long you should be able to jump straight to the bottom by pressing uppercase G

You can also probably get a tty in vmware with ctrl+alt+f3 so you don’t have to access it remotely. If your host is also Linux than you can use ctrl+alt+space+f3 instead to stop the host from catching the sequence and switching to a TTY.

3 Likes

Thank you for your reply.

systemctl status --full gdm.service

doesn’t show any error messages.
And I can’t find any error messages concerning gdm by

journalctl -p err

After switching to multi-user.target, I recorded the log by

journalctl -f | tee error.log

then execute from remote terminal

sudo systemctl isolate graphical.target

In the error.log there are

7月 08 19:59:59 fedora32-vmf /usr/libexec/gdm-wayland-session[2057]: dbus-daemon[2057]: [session uid=42 pid=2057] Activating service name=‘org.freedesktop.systemd1’ requested by ‘:1.1’ (uid=42 pid=2061 comm="/usr/libexec/gnome-session-binary --autostart /usr" label=“system_u:system_r:xdm_t:s0-s0:c0.c1023”)
7月 08 19:59:59 fedora32-vmf /usr/libexec/gdm-wayland-session[2057]: dbus-daemon[2057]: [session uid=42 pid=2057] Activated service ‘org.freedesktop.systemd1’ failed: Process org.freedesktop.systemd1 exited with status 1
7月 08 19:59:59 fedora32-vmf audit: NETFILTER_CFG table=filter family=10 entries=6
7月 08 19:59:59 fedora32-vmf /usr/libexec/gdm-wayland-session[2057]: dbus-daemon[2057]: [session uid=42 pid=2057] Activating service name=‘org.freedesktop.systemd1’ requested by ‘:1.2’ (uid=42 pid=2061 comm="/usr/libexec/gnome-session-binary --autostart /usr" label=“system_u:system_r:xdm_t:s0-s0:c0.c1023”)
7月 08 19:59:59 fedora32-vmf /usr/libexec/gdm-wayland-session[2057]: dbus-daemon[2057]: [session uid=42 pid=2057] Activated service ‘org.freedesktop.systemd1’ failed: Process org.freedesktop.systemd1 exited with status 1
7月 08 19:59:59 fedora32-vmf gnome-session[2061]: gnome-session-binary[2061]: WARNING: Falling back to non-systemd startup procedure due to error: GDBus.Error:org.freedesktop.DBus.Error.Spawn.ChildExited: Process org.freedesktop.systemd1 exited with status 1
7月 08 19:59:59 fedora32-vmf gnome-session-binary[2061]: WARNING: Falling back to non-systemd startup procedure due to error: GDBus.Error:org.freedesktop.DBus.Error.Spawn.ChildExited: Process org.freedesktop.systemd1 exited with status 1
7月 08 19:59:59 fedora32-vmf audit: NETFILTER_CFG table=filter family=10 entries=7
7月 08 19:59:59 fedora32-vmf /usr/libexec/gdm-wayland-session[2057]: dbus-daemon[2057]: [session uid=42 pid=2057] Activating service name=‘org.freedesktop.systemd1’ requested by ‘:1.2’ (uid=42 pid=2061 comm="/usr/libexec/gnome-session-binary --autostart /usr" label=“system_u:system_r:xdm_t:s0-s0:c0.c1023”)
7月 08 19:59:59 fedora32-vmf /usr/libexec/gdm-wayland-session[2057]: dbus-daemon[2057]: [session uid=42 pid=2057] Activated service ‘org.freedesktop.systemd1’ failed: Process org.freedesktop.systemd1 exited with status 1
7月 08 19:59:59 fedora32-vmf /usr/libexec/gdm-wayland-session[2057]: dbus-daemon[2057]: [session uid=42 pid=2057] Activating service name=‘org.freedesktop.systemd1’ requested by ‘:1.2’ (uid=42 pid=2061 comm="/usr/libexec/gnome-session-binary --autostart /usr" label=“system_u:system_r:xdm_t:s0-s0:c0.c1023”)
7月 08 19:59:59 fedora32-vmf audit: NETFILTER_CFG table=filter family=10 entries=9
7月 08 19:59:59 fedora32-vmf /usr/libexec/gdm-wayland-session[2057]: dbus-daemon[2057]: [session uid=42 pid=2057] Activated service ‘org.freedesktop.systemd1’ failed: Process org.freedesktop.systemd1 exited with status 1
7月 08 19:59:59 fedora32-vmf audit: NETFILTER_CFG table=filter family=10 entries=10
7月 08 19:59:59 fedora32-vmf /usr/libexec/gdm-wayland-session[2057]: dbus-daemon[2057]: [session uid=42 pid=2057] Activating service name=‘org.freedesktop.systemd1’ requested by ‘:1.2’ (uid=42 pid=2061 comm="/usr/libexec/gnome-session-binary --autostart /usr" label=“system_u:system_r:xdm_t:s0-s0:c0.c1023”)
7月 08 19:59:59 fedora32-vmf /usr/libexec/gdm-wayland-session[2057]: dbus-daemon[2057]: [session uid=42 pid=2057] Activated service ‘org.freedesktop.systemd1’ failed: Process org.freedesktop.systemd1 exited with status 1
7月 08 19:59:59 fedora32-vmf audit: NETFILTER_CFG table=filter family=10 entries=12
7月 08 19:59:59 fedora32-vmf audit: NETFILTER_CFG table=filter family=10 entries=13
7月 08 19:59:59 fedora32-vmf /usr/libexec/gdm-wayland-session[2057]: dbus-daemon[2057]: [session uid=42 pid=2057] Activating service name=‘org.freedesktop.systemd1’ requested by ‘:1.2’ (uid=42 pid=2061 comm="/usr/libexec/gnome-session-binary --autostart /usr" label=“system_u:system_r:xdm_t:s0-s0:c0.c1023”)
7月 08 19:59:59 fedora32-vmf audit: NETFILTER_CFG table=filter family=10 entries=15
7月 08 19:59:59 fedora32-vmf /usr/libexec/gdm-wayland-session[2057]: dbus-daemon[2057]: [session uid=42 pid=2057] Activated service ‘org.freedesktop.systemd1’ failed: Process org.freedesktop.systemd1 exited with status 1aces

gdm-wayland-session seems to fail but I cannot find out what prevents gdm-wayland-session from starting.

My problem seems as same as this thread.
According to the thread, I updated Fedora 32 by

$ sudo dnf update --exclude kernel*

and it was successfully rebooted.

In my environment, kernel-5.7.7-200.fc32 seems not to be able to start gdm normally.

My environment is the followings.
Hardware: iMac 21.5 inch late 2013 (Core i5, 16GB DRAM).
Host OS: macOS 10.15.5
Virtualization by VMware Fusion Pro 11.5.5
Virtual machine 2 CPUs, 3072MB memory

The above thread, MacBook Pro is used as the hardware.
So this problems may be related to Mac hardware.

1 Like

I think I have the same problem as you.
Meanwhile I am stuck with Fedora 5.6.19-300 and I cannot upgrade it.
Maybe I’ll try to disable wayland.
From journalctl
Jul 13 07:41:30 nero32 /usr/libexec/gdm-wayland-session[1101]: dbus-daemon[1101]: [session uid=42 pid=1101] Activating service name=‘org.freedesktop.systemd1’ requested by ‘:1.1’ (uid=42 pid=1102 comm="/usr/libexec/gnome-session-binary --autostart /usr")
Jul 13 07:41:30 nero32 /usr/libexec/gdm-wayland-session[1101]: dbus-daemon[1101]: [session uid=42 pid=1101] Activated service ‘org.freedesktop.systemd1’ failed: Process org.freedesktop.systemd1 exited with status 1

In the log in session, I tried choosing Gnome on Xorg and rebooting. However, I still got only black screen after rebooting.
The login session seems to be presented by wayland.
I don’t know how to disable wayland and enable Xorg instead. If you succeed to disable wayland and enable Xorg from in the login session, please let me know.
regards,

To disable wayland I edited the file /etc/gdm/custom.conf

You may also enable debugging.

gdm-wayland-session now starts normally after updating the kernel to 5.7.10-201.fc32.

Thank you!