Geogebra on Fedora 32

Hi folks, I was trying to install Geogebra on my computer and I stumbled upon these issues:

dnf install geogebra-classic
Última verificação de data de vencimento de metadados: 1:56:05 atrás em sáb 09 mai 2020 22:03:24.
Erro:
Problema: conflicting requests

  • nothing provides /usr/lib64/libmpfr.so.4 needed by geogebra-classic-6.0.577.0-202004201951.x86_64
  • nothing provides /usr/lib64/libmpfr.so.4 needed by geogebra-classic-6.0.578.0-202004220150.x86_64
  • nothing provides /usr/lib64/libmpfr.so.4 needed by geogebra-classic-6.0.579.0-202004231811.x86_64
  • nothing provides /usr/lib64/libmpfr.so.4 needed by geogebra-classic-6.0.580.0-202004301510.x86_64
  • nothing provides /usr/lib64/libmpfr.so.4 needed by geogebra-classic-6.0.581.0-202005072231.x86_64
    (try to add ‘–skip-broken’ to skip uninstallable packages)

In the old version of Fedora I had no problems, but in this current one it appeared.

I followed the tip of this other post here:
https://ask.fedoraproject.org/t/dnf-reports-geogebra-gpg-key-not-found/3376

I imported the key and updated the repositories. Then, I tried to install the package geogebra-classic but it lacked that mpfr library. So I tried to install this package with a:

dnf install mpfr

but the package was already installed. When I tried to use the “–skip-broken” he simply ignored the package and did not install it. Has anyone had a similar problem?

Hello @thiagotabosa and welcome to the community! Please read the posts in the #start-here if you’ve not had the chance to do so yet.

The point with Geogebra is that Fedora 32 provides libmpfr.so.6 while the geogebra package wants libmpfr.so.4

So, you should report this issue to geogebra (maybe asking in their forum? https://help.geogebra.org/)

Meanwhile you can give a try to the Flatpak version (https://flathub.org/apps/details/org.geogebra.GeoGebra)

1 Like

With Fedora 32 I was able to install via Flatpak and it worked perfectly. In the previous version, I was able to install it but once installed the program would not open. I was only able to open it when I typed the command in the terminal. Thank you for your help.

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.