Getting the function keys to work properly with a Varmilo keyboard

Hi, I recently installed fedora 33, previously running Arch. I have a Varmilo VA88M keyboard.

The keyboard identifies as an Apple keyboard in Linux, which causes the F1-F12 keys to not function as they should.

2 Likes

In Arch, the solution to this was to add /etc/modprobe.d/hid_apple.conf with the contents:
options hid_apple fnmode=2

In fedora, this alone does not work, however I found that creating /etc/dracut.conf.d/hid_apple.conf with the contents:
install_items+=/etc/modprobe.d/hid_apple.conf
and then regenerating initramfs with
dracut --force
solved my problem.

I hope this will help any others out there with a Varmilo keyboard.

2 Likes