GNOME-Boxes Not working

Hi,

I am using Fedora 32 (GNOME-3.36) with Virtualization enabled in BIOS. But I am getting this error while creating a VM from ISO File.

Please, Help.

/******************************/

gnome-boxes --check gives this

• The CPU is capable of virtualization: yes
• The KVM module is loaded: yes
• Libvirt KVM guest available: no
• Boxes storage pool available: yes
• The SELinux context is default: yes

virsh -c qemu:///session pool-dumpxml gnome-boxes gives this

<code>
<pool type='dir'>
  <name>gnome-boxes</name>
  <uuid>a5cd405a-e6a4-43e0-91d1-b9c0db31725d</uuid>
  <capacity unit='bytes'>78201524224</capacity>
  <allocation unit='bytes'>8573784064</allocation>
  <available unit='bytes'>69627740160</available>
  <source>
  </source>
  <target>
    <path>/home/$USER/.local/share/gnome-boxes/images</path>
    <permissions>
      <mode>0744</mode>
      <owner>1000</owner>
      <group>1000</group>
      <label>unconfined_u:object_r:svirt_home_t:s0</label>
    </permissions>
  </target>
</pool>
</code>

It seems that some of the packages are not installed. Are you running a fresh installation, or is it an upgrade from F31?
For the start, you can try the following commands

rpm -qa libvirt

and

rpm -qa libvirt-client.

Do you have the packages?

2 Likes

Further tips:

  • Make sure libvirt and libvirt-client are installed.
  • Make sure, that everything is up-to-date, run sudo dnf update --refresh to confirm.
  • Try running gnome-boxes from the terminal and see if it spits out any useful information.
  • Run sudo virt-host-validate for further info.
  • Also, you can try to (re)install the “Fedora Workstation” group - sudo dnf groupinstall "Fedora Workstation" - Boxes work out of the box in basic Fedora Workstation installation, maybe you tried to build the system from Fedora Minimal or Fedora Basic and you skipped an important package.
2 Likes

Hi @daveleedave,
please be aware that there is no such thing as Fedora 32 as of now. Fedora 32 is in beta stage which is meant for testing - audience are developers or power users. In order to run a beta in production, it is recommended that you can troubleshoot potential bugs and report them to the developers so it can be fixed before the release.

if you want your system simply to work and not deal with the missing pieces in an unreleased distro, I would strongly suggest to run Fedora 31. The differences are marginal but you certainly get a stable platform. Once F32 is released (or a few weeks after), you can upgrade and enjoy the best Fedora ever…

1 Like

As simple as:

Regards.,

1 Like

I didn’t have those packages. But even after Installing them I still have the same issue.
Check updated Question.

I also have user added in Libvirt group
usermod -aG libvirt $USER

sudo virt-host-validate gives this

<code>
  QEMU: Checking for hardware virtualization                                 : PASS
  QEMU: Checking if device /dev/kvm exists                                   : PASS
  QEMU: Checking if device /dev/kvm is accessible                            : PASS
  QEMU: Checking if device /dev/vhost-net exists                             : PASS
  QEMU: Checking if device /dev/net/tun exists                               : PASS
  QEMU: Checking for cgroup 'cpu' controller support                         : WARN (Enable 'cpu' in kernel Kconfig file or mount/enable cgroup controller in your system)
  QEMU: Checking for cgroup 'cpuacct' controller support                     : PASS
  QEMU: Checking for cgroup 'cpuset' controller support                      : WARN (Enable 'cpuset' in kernel Kconfig file or mount/enable cgroup controller in your system)
  QEMU: Checking for cgroup 'memory' controller support                      : PASS
  QEMU: Checking for cgroup 'devices' controller support                     : PASS
  QEMU: Checking for cgroup 'blkio' controller support                       : WARN (Enable 'blkio' in kernel Kconfig file or mount/enable cgroup controller in your system)
  QEMU: Checking for device assignment IOMMU support                         : PASS
  QEMU: Checking if IOMMU is enabled by kernel                               : PASS
   LXC: Checking for Linux >= 2.6.26                                         : PASS
   LXC: Checking for namespace ipc                                           : PASS
   LXC: Checking for namespace mnt                                           : PASS
   LXC: Checking for namespace pid                                           : PASS
   LXC: Checking for namespace uts                                           : PASS
   LXC: Checking for namespace net                                           : PASS
   LXC: Checking for namespace user                                          : PASS
   LXC: Checking for cgroup 'cpu' controller support                         : FAIL (Enable 'cpu' in kernel Kconfig file or mount/enable cgroup controller in your system)
   LXC: Checking for cgroup 'cpuacct' controller support                     : PASS
   LXC: Checking for cgroup 'cpuset' controller support                      : FAIL (Enable 'cpuset' in kernel Kconfig file or mount/enable cgroup controller in your system)
   LXC: Checking for cgroup 'memory' controller support                      : PASS
   LXC: Checking for cgroup 'devices' controller support                     : PASS
   LXC: Checking for cgroup 'freezer' controller support                     : FAIL (Enable 'freezer' in kernel Kconfig file or mount/enable cgroup controller in your system)
   LXC: Checking for cgroup 'blkio' controller support                       : FAIL (Enable 'blkio' in kernel Kconfig file or mount/enable cgroup controller in your system)
   LXC: Checking if device /sys/fs/fuse/connections exists                   : PASS
</code>

Also, there is a new important update for libvirt and qemu in updates-testing which might help you. Try to update your machine:

sudo dnf update --enablerepo=updates-testing

Hope this helps.

1 Like

This is not needed, @daveleedave is runnning a beta release in which the updates-testing repo is enabled by default (beta := testing).

Did you try to mount the cgroups manually as described in

http://man7.org/linux/man-pages/man7/cgroups.7.html#CGROUPS_VERSION_1

This could also be an issue on how the kernel was compiled…

In any case, I would report this to the the developes (bugzilla.redhat.com, component: Gnome Boxes)

I am also running Fedora 32 and Boxes (after that update) work fine. If @daveleedave is running a standard Fedora, there is no reason why his Boxes should not work I think (except for hardware related stuff).

But yeah, he can always report it as a bug.

1 Like

No I didn’t do anything related to cggroup. I installed a Minimal version from Everything ISO.

I also have the same problem on Silverblue 32beta , even flatpak Boxes gives me the error about no virtualization extensions though they are enabled in BIOS and show up in cpuinfo.

1 Like

Were you able to fix it?

Please, report it as a Silverblue bug.

1 Like

Silverblue is a very different system to a standard workstation install. Please open a new topic for it, or report a bug against Silverblue separately.

1 Like

Did you actually manage to fix the problem? If yes, could you please let us know? Thanks!

1 Like