Gnome Boxes works only as root

Hi! :slight_smile: I’m just getting started with Fedora and came across a problem.

Starting Gnome Boxes via the application launcher gives me an error stating that “Virtualization extensions are unavailable on your system”.

I poked around the BIOS settings and even installed a UEFI update, to no avail (which didn’t surprise me because I’ve used a few applications requiring VT-x on this machine in the past). Turns out, it works just fine by executing sudo gnome-boxes in a terminal, but that’s a bit janky for daily use. Interestingly, managing Qemu/KVM machines using virt-manager works just fine if I open it from the applications menu without root privileges.

Is there a non-hacky fix for this? I’d like to avoid modifying the .desktop file or something like that.

Here’s the output of gnome-boxes --checks:

Thank you, all the best
slope

1 Like

Hi @slope, welcome to the community! Please take a minute to go through the introductory post in #start-here if you’ve not had a chance. It contains some useful information on using this platform.

This is very odd. Gnome-boxes should not require root privileges as far as I know. Is this a fresh install? Could you check the messages in the journal when you run gnome-boxes to see what it says? Could be a permissions error:

https://docs.fedoraproject.org/en-US/quick-docs/viewing-logs/

Exact same issue as

Unfortunately, no answer marked as Solution. Is your system fully up-to-date?

Hello you two,

I’ve made some progress: this behavior happens only with a specific, downloaded ISO (Ubuntu 20.04). Should’ve checked that beforehand, sorry :frowning: Fedora ISOs that I had laying around work fine. Still weird though that this Ubuntu ISO works if I start Boxes as root.

Unfortunately I can’t test if the images work that Boxes can download for me, due to a very slow internet connection. but I guess that means this is solved.

Thank y’all!

For the record: my system was installed a few days ago, I’ve just installed some packages and poked around in the settings a bit but nothing more. It’s fully up to date.

1 Like

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.