Gnome does not save Bluetooth Status on power off

Hello,

i have a issue with Bluetooth on Fedora 35.
Bluetooth is always turned on at system startup, i toggle the switch to OFF status before shut down so the expected behavior should be that system saves the BT status to off and upon start of system it should be in OFF status.
but its always turned on.
system has linux kernel 5.15.12-200.fc35.x86_64
there was no issue with KDE version of Fedora 35.
i use a wireless mouse from Logitech with a dongle and its not connected via BT as it works even if the BT is turned off.
pls share if any suggestions.

Not sure if this the right way to disable auto enable bluetooth. But you can change the config /etc/bluetooth/main.conf. On near of very bottom part, there a setting AutoEnable=true, change it to false.

1 Like

Thanks !!
This fixed the issue.