Gnome is not working after upgrade from 29 to 30 (dnf)

Hi,

After upgrading to fedora 30 using dnf gnome session won’t start. I’m getting only black screen with a mouse pointer. XFCE is working fine. Any recommendations on how to fix GNOME?

1 Like

Hi @ursusca! Welcome to the Fedora community!

Could we have some information to see what may have gone wrong?

  • What method did you use to upgrade? Was it dnf system-upgrade?
  • Did the upgrade (and the reboot) go through properly? Did you notice any errors/warnings?
  • Can we have some information on your hardware? (Outputs of lspci and lsusb commands when run in a terminal) This is useful to see if it’s something like NVIDIA kernel modules that may be causing issues.
  • Does GDM work—or does that not come up either?
  • If GDM does come up, and then GNOME does not, it could be Gnome shell extensions causing Gnome to crash. The simplest way to test this is to create a new user and see if you can login there (no extensions here).

I think that’s quite a bit to start the diagnostic process :smile:

Discourse allows you to reply with lots of formatting etc. Please take a look at the user-guide to see how this works: https://meta.discourse.org/t/discourse-new-user-guide/96331. We’ve also summarised tips and tricks in the #start-here category.

Is there a way to log into an account that has been pootched due to GNOME extentions, and disable all the GNOME extentions so you can access the account?

So log in, not using a graphic environment:

systemctl set-default multi-user.target

reboot

…and then do …what?

1 Like

One can disable gnome-shell extensions using the gnome-shell-extension-tool on the terminal if it is installed. Please run gnome-shell-extension-tool --help for more information on how to use it. You can get the ids for the extensions from their locations:

ls ~/.local/share/gnome-shell/extensions/

The system-extensions should not be the issue, but we’ll see.

You can access a virtual terminal using ctrl + alt + f2. Here, since XFCE works, one can login there and run the required command.

However, the reason we suggest a new user is to check whether the issue persists in a pristine user account—disabling gnome-shell extensions is only a part of that.

Hi Francisco,

Thank you for your help!

I did dnf upgrade as described in https://fedoramagazine.org/upgrading-fedora-29-to-fedora-30/

And you are right, the issue is with extensions. I use a lot of extensions and all of them are from Fedora repositories. I created new user and GNOME session starts fine for new user.

I’ll try to disable extensions.

1 Like

Ah–awesome—I’ve also updated my post with some more information on locally installed extensions.

I’m not sure why but there no extensions folder in ~/.local/share/gnome-shell/

I’m using the following command to get the extensions list

$ gsettings get org.gnome.shell enabled-extensions
['background-logo@fedorahosted.org', 'apps-menu@gnome-shell-extensions.gcampax.github.com', 'dash-to-dock@micxgx.gmail.com', 'places-menu@gnome-shell-extensions.gcampax.github.com', 'extensions@abteil.org', 'caffeine@patapon.info', 'workspace-indicator@gnome-shell-extensions.gcampax.github.com', 'gnomenu@panacier.gmail.com', 'Move_Clock@rmy.pobox.com', 'shell-volume-mixer@derhofbauer.at', 'clipboard-indicator@tudmotu.com', 'drop-down-terminal@gs-extensions.zzrough.org']

Unfortunately, disabling extensions using gnome-shell-extension-tool didn’t help. The solution for me is to create new user_home directory and install/configure extensions again.

I had this issue, too.
Disabling extensions as proposed by FraciscoD did it for me. I’m happy again…

Ouuups. My Gnome session crashed when entering the word “extension” in the address bar of my browser :astonished:

And now the loop is back m(

Ah weird. Is there an extensions folder in there? That’s where all user installed extensions are meant to go. If you’ve installed extensions using dnf, they go in system directories, but should be uninstallable using dnf remove ....

You can use a tty: ctrl + alt + f2, login there, and use the gnome-shell-extension-tool to disable them. I’ve had to do it once or twice. (Or you can install another DE, and use gnome-tweak-tool there)

Yeah, I had to do that again :face_with_symbols_over_mouth:

But the point is: just typing “extensions” into the address bar of my browser made the session crash. After re-disabling all extensions, it came up again.

However, there must be something terribly wrong with the implementation of gnome extensions, as some are enabled but the effects are very odd… :face_with_monocle:

2 Likes

Extensions that are not maintaned by GNOME go through a review process before they are included on the extension store. However, like software in general, these must be maintained: bugs fixed, updated to new APIs. When that is not done regularly, things break.

So, here, you’ll have to disable them all and enable them one by one to see which ones cause the breakage, and then report these bugs to their developers (and provide fixes if you can to help them out).

1 Like

I had the same issue, I could get to the desktop, but no icons or anything all missing. If you can get to a term then try this command.

sudo dnf install chrome-gnome-shell

Once I did this it worked and my desktop came back. Icons and all. Hope it helps!

Thanks,
Miss. McKnight

Hello @missmcknight. Welcome to the community!

Any idea why that worked? Did it install/remove or update other packages too?

I do not believe it install any other packages. It only showed the one. I did notice when installing Fedora 30 it would fail with an issue with google single signon and some other package which I had to remove to continue the install. It might be what caused my issue. I will see what my other system does once I move it to F30 tonight. I will post my results. It also does not have Gnome extensions installed .

Thanks,
Miss. McKnight

1 Like

Solved my Log in loop issue. It was an extension. FransciscoD’s info was the key.
Thanks to mcbuhl for his input
PD

1 Like

Hello. Do you remember which extension was problematic?

I’ve opened a pull request here on quick-docs about using and managing gnome-shell-extensions: https://pagure.io/fedora-docs/quick-docs/pull-request/137

@parleedave @mcbuhl @ursusca @thebigduck - would any of you like to review it please? You already have an FAS, so you can login to pagure.io too. The steps would be:

  • clone the quick-docs repo (requires git to be installed: git clone https://pagure.io/fedora-docs/quick-docs.git, then enter the newly created quick-docs directory.
  • fetch my branch: git fetch https://pagure.io/fedora-docs/quick-docs.git refs/pull/137/head:pr137
  • checkout the PR branch: git checkout pr137
  • Build and preview the docs: ./build.sh && ./preview.sh. This will require either docker or podman to be installed. It will first fetch the antora etc. docker images (only the first time), so please be patient :slightly_smiling_face:

Then, you can comment on the pull request here: https://pagure.io/fedora-docs/quick-docs/pull-request/137#request_diff Click next to a line number to leave a comment there.

1 Like