GNOME login screen options reordered

Hello,

I’ve multiple computers running Fedora 35 with default GNOME desktop environment. GNOME login screen normally has three options: ‘GNOME’, ‘GNOME Classic’, and ‘GNOME on Xorg’. However, on my desktop I noticed, the order of the options under the gear icon changed ‘behind the scenes’, so now I have ‘GNOME’, ‘GNOME Classic’, and ‘GNOME on Wayland’.

I can’t find out why the options have been reordered/swapped, as I made no proactive changes to it. Do you know why this happens, and if there is a way to revert it back to default ordering of options (Wayland being the default, ‘GNOME on Xorg’ being the third)?

On this PC I’m having an nVidia video card, and also run propreitary nVidia driver. Do you think changes happened when I installed (and changed to) nVidia driver instead of Nouveau?

Thank you in advance,
Márton Lente

1 Like

I think for Fedora releases 35 and before, using the nvidia proprietary driver meant GDM (the login manager) could only use X11, and the default for Gnome shell was also X11. That’ll be why you now have an option to run “Gnome on Wayland”. With nouveau, GDM would use wayland as would gnome-shell, and so you’d get “Gnome on X” as an option.

With F36+, GDM now also defaults to Wayland (see the “other updates” section of the announcement):

2 Likes

Hello,

Thanks @ankursinha for the detailed clarification! Then it must be the reason, and I look forward to upgrade to Fedora 36, once it’s available. :slightly_smiling_face:

1 Like

Actually, in my experience, the options change depending on whether you are using wayland or xorg.

When you log in running wayland the option the next time you log in displays “Gnome on Xorg”. When you select to login using xorg then the next time it displays “Gnome on Wayland”. Thus the default is the last one used and the selection allows you to pick the other the next time if you wish.

Hello,

Thanks @computersavvy for sharing your experience. I tested this though, and it doesn’t work in my case (even though it would be the expected behavior). On my PC the ‘Gnome on Wayland’ option is always the third – the options’ layout doesn’t change: no matter on what my latest session run.

I’ll share if upgrading to Fedora 36 resolved the issue soon.

I just tested on my fedora 36 system. The 2 screenshots shows the difference. The first (with the dot beside ‘GNOME’) was after I had previously logged in with wayland. The second (with the dot beside ‘GNOME on Xorg’) was after I had logged on using Xorg. So the list is the same but the dot shows last used on that system.

Screenshot from 2022-04-01 13-51-32

Screenshot from 2022-04-01 13-53-28

I then tried the same on my fedora 35 machine and see the difference.
On that system there are only 3 options, GNOME, GNOME Classic, and GNOME on Wayland. The dot still shows the last option used, but the default there (GNOME) is using Xorg and not wayland. My F36 system is running in a VM so it defaults cleanly to wayland.

My interpretation of the info from those 2 screenshots is that the default for f36 (GNOME) is wayland and only if the option says Xorg does it use xorg. I would guess the change from the options on f35 is due to the switch from gnome 41 to gnome 42.

It seems I may have misremembered what was displayed at that gear, and you are correct in that the options are always in the same order. I seldom switch what I use and have always used X because of nvidia GPUs on all machines. I see that the dot displays the last used option instead of the option text changing.

edit:
I went back to a vm with a clean install of f33 and there I see the same as f35 except that the last option is for ‘Gnome on Xorg’. F33 was the first to use wayland as the default.

2 Likes

Hello,

Thanks @computersavvy for the very thorough answer, and testing! :slight_smile:

Then the tests basically confirm the above assumptions, so that it seems my questions are fully clarified now. :+1: