Gnome Settings Date & Time show all timezones as UTC

Hello!

I am a problem where Gnome Settings Date & Time as well as the time in the top panel are showing UTC while my clock is actually set to a local time.


timedatectl appears as I would expect:
[~] $ timedatectl 
               Local time: Thu 2022-12-01 11:07:17 CST
           Universal time: Thu 2022-12-01 17:07:17 UTC
                 RTC time: Thu 2022-12-01 17:07:17
                Time zone: America/Chicago (CST, -0600)
System clock synchronized: yes
              NTP service: active
          RTC in local TZ: no
[~] $ date
Thu Dec  1 05:08:03 PM America 2022
[~] $ echo $TZ
America/Chicago

However, the settings dialog and top panel show the UTC time. The timezone picker also let’s me select different areas, but the offset is always 00:00 and named UTC.

The time in firmware should be set to UTC and the local timezone should be set. With that it all should work properly.

I use the same settings as you, but the difference I see is that

  1. I have the Automatic Time Zone disabled because location services are disabled, you have it turned off.
  2. I have no $TZ value.

Everything else seems the same and my display is correct.

$ timedatectl
               Local time: Thu 2022-12-01 12:16:55 CST
           Universal time: Thu 2022-12-01 18:16:55 UTC
                 RTC time: Thu 2022-12-01 18:16:56
                Time zone: America/Chicago (CST, -0600)
System clock synchronized: yes
              NTP service: active
          RTC in local TZ: no

$ date
Thu Dec  1 12:26:04 PM CST 2022

$ echo $TZ

The problem seems to be more with Settings in Gnome, as far as I can tell.

timedatectl shows what is correct. Local time is show in CST. RTC is in UTC, Time zone (and offset) is correct.

However, in Settings, even if I disable automatic date, time, and timezone every option available is “UTC (UTC+00)”. I can choose a zone different from mine, and it will adjust the time based on the offset. If I search for New York for example, the box still shows UTC (UTC+00), but the time is no -1 hour.

If I save this now, it will update the output of timedatectl and make the RTC wrong, since it’s setting UTC to now and not the real time.

Maybe this animation helps explain the above better.
output

Is the location services running?
I disable that during the initial setup at first boot immediately after install.

Let me test again with a new install of F37 to verify what I already stated. Will be back quickly

Did a full new install of F37 and all the date & time settings and configs work as expected.
It seems something must have gotten corrupted either in your install or with an update.

Have you tried sudo dnf reinstall gnome-control-center to see if the error may be fixed that way? Gnome-control-center AKA ‘Settings’ in the activities menu.

Have you tried sudo dnf reinstall gnome-control-center to see if the error may be fixed that way? Gnome-control-center AKA ‘Settings’ in the activities menu.

Just tried this a short bit ago. Did not seem to help.

I created a new account, and logged in with that account. There, timedatectl matched, but the clock was showing the correct timezone. And in Gnome Settings > Date & Time the Time Zone was listed as CST (Chicago, United States) and not UTC (Chicago, United States).

So, this seems something only related to this particular account? Worth nothing here, this was “working as expected” for quite some time and only has become a problem in the last few days.

There are three files in my home directory, .gnome, .gnome2, and .gnome-private that are part of the user config. There is also ~/.config/gnome-control-center, ~/.config/gconf and other gnome related files.
I suspect if you can compare the content of each with the same for the new user you may be able to identify what is different and fix the issue.

Your comment that it is Worth nothing here seems incorrect in that it narrows the issue down to a user config and not a system issue.

I don’t seem to have many of those folders/files. There is not .gnome, .gnome2, .gnome-private, or .config/gconf.

$ find .config/gnome-control-center/
.config/gnome-control-center/
.config/gnome-control-center/backgrounds
.config/gnome-control-center/backgrounds/last-edited.xml

I do agree this is a local account problem, and not a system wide issue. Still have no idea how to resolve it or why it’s happening though.

I do have a ~/.config/dconf/user, which if I removed and logged back in, I see that all settings have been reset as expected, but the TZ issue still persists.

Many released ago they held the configuration files for Gnome. gconf was replaced by dconf for example.

In reviewing differences between the account that works and the one that doesn’t I noticed the non-working account was using X11 and the working was Wayland.

So, I logged out of the account that wasn’t show correct TZ, and logged back in selecting “Gnome” only. Time is displayed correctly. And the TZ chooser shows that expected info.

Logout, choose Gnome on X11 and the weirdness returns.

I tried this on the new account I created (logging in Gnome on X11) and do not seem to have the issue immediately.

That reaction as a difference between xorg and wayland seems strange. Have not seen such myself. Mine is always the same as you said the new user account shows.