Gnome shell calendar goes over API limit

I added two Google accounts to my online accounts in Gnome and allowed syncing of the calendar. This works just fine for the default Gnome shell calendar, initially. All in all I have about 10 different calendars in those accounts.

I recently noticed some of the changes to my events were not showing up either in Fedora or on another device that connects to the same accounts. I tried syncing, restarting the desktop session and even a full restart, to no avail. Then I looked into the system logs and found countless messages like this one:

source_credentials_required_cb: Failed to authenticate ‘’: Daily Limit Exceeded. The quota will be reset at midnight Pacific Time (PT). You may monitor your quota usage and adjust limits in the API Console: https://console.developers.google.com/apis/api/caldav.googleapis.com/quotas?project=44438659992

This happens for all of my calendars, apparently from the logs. It also suggests that it will resolve the syncing issues eventually, but this is obviously not the expected behaviour :slight_smile:

Is this an issue with the app itself? The link provided does not allow public access.

1 Like

Hi @tiesebarrell! Welcome to Fedora! Please take a minute to go through the introductory posts in #start-here if you’ve not had a chance to do so yet.

It is actually expected behaviour. There’s a limit to the number of API calls that can be made for each account:

https://developers.google.com/analytics/devguides/config/mgmt/v3/limits-quotas

(This goes for most servies: Google/Hotmail/Yahoo/Twitter/Facebook.)

The rate limits are generally sufficient though. Are you manually syncing your calendars often?

1 Like

Hi @FranciscoD and thanks for the welcome :slight_smile:

I wasn’t manually syncing anything until I started noticing the inconsistencies between my calendars. TBH, I then started trying the Sync Calendars option, but since it gives little to no feedback on what happens, it wasn’t clear to me whether it was syncing which calendars there are in the account or the actual content of them. As far as I can tell, there’s no configuration you can do to set the automatic sync frequency either.

I also never saw any problems before in other apps. Of course it might be that I just went over the limit by adding them to the calendar in Fedora, but the others were still working and syncing in the mean time.

The documentation you point to is for Google Analytics API by the way, so I’m not sure that applies to this case, even though there might be similar limits in place for Calendar.

2 Likes

It looks like the limit to the API for Calendar is on the app that accesses it:

https://developers.google.com/calendar/pricing

2 Likes

I wonder if that’s per account, or per project (Gnome as a project?). If it were a project level issue, though, all users would be seeing such errors (or so I think?).

Yes, that’s what’s strange to me too. I seems unlikely that my few extra requests are the ones that took the whole group over the limit. That page is findable through a search, but I couldn’t find it linked for context, unfortunately. The wording is not that clear, although it is on the developer resources.

1 Like

Issue tracked here:

2 Likes