Gnome-shell. How to activate numlock on when logging in?

So, how do I activate numlock when I enter the Gnome (Wayland) session?
Thanks.

1 Like
gsettings set org.gnome.settings-daemon.peripherals.keyboard remember-numlock-state true
gsettings set org.gnome.settings-daemon.peripherals.keyboard numlock-state on
2 Likes

Thanks but I forgot to say that I’m using Fedora 31 with Gnome Shell 3.34 and these settings don’t exist:

$ gsettings set org.gnome.settings-daemon.peripherals.keyboard remember-numlock-state true
No such key "remember-numlock-state"
$ gsettings set org.gnome.settings-daemon.peripherals.keyboard numlock-state on
No such key "numlock-state"

In Gnome Shell 3.34 have these names:

org.gnome.desktop.peripherals.keyboard remember-numlock-state
org.gnome.desktop.peripherals.keyboard numlock-state

But it doesn’t work. I’ve opened a bug report: https://bugzilla.redhat.com/show_bug.cgi?id=1754280

3 Likes
gsettings list-recursively | grep -e numlock

What does it say?

1 Like
$ gsettings list-recursively | grep -e numlock                                                                                                    
org.gnome.desktop.peripherals.keyboard remember-numlock-state true
org.gnome.desktop.peripherals.keyboard numlock-state false
2 Likes