Gnome Software notifications problem

Hello,
I use Fedora 30 Workstation and Gnome Software for the installation of the updates.
But G. S. notifies me the updates only when the software is already running, and without the pop-up windows at the top of the screen in the background (that’s an incorrect behaviour, in my opinion).
What can I do to solve this problem?
Thanks a lot in advance.

Ciao @gpanebianco! And welcome to the community. Please do take a few minutes to go over the introductory posts in #start-here when you have the time. They contain lots of useful information.

I don’t know what happens, Gnome Software notifications work here, but we could try to debug the problem.
Could you provide the result of these commands?
gsettings get org.gnome.software check-timestamp
gsettings get org.gnome.software install-timestamp
date +"%s"

Do you have any particular repository enabled?
(Stupid question) Is the time/date of your PC ok?

In addition, just after the login, is gnome-software running in the background?
ps -auwx|grep gnome-software

Schermata%20da%202019-07-26%2013-24-47
I have uploaded a screenshot of my terminal with all the datas you require.
In addition, I have to tell you that I use google-chrome, vivaldi, skype, flathub and some RPMFusion repositories.
My date/time is correct.

Well, it seems OK.
You could try these steps, in order to force the notification to appear, if they even work.

gsettings set org.gnome.software check-timestamp $(date '+%s' --date='18:00 2 days ago')

gsettings set org.gnome.software install-timestamp $(date '+%s' --date='08:00 8 days ago')

sudo touch --no-create --date='08:00 8 days ago' /var/lib/PackageKit/offline-update-competed

Then log out or reboot.
As soon as logged in again, open a terminal and issue the command pkmon.
You should see some works, like progress percentages. When all the progresses stop, the notification should pops up. …if all is working as it should.
Try to see if some error appears in this terminal.

Or, is it possible that in gnome settings you have disabled gnome-software from showing notifications? (I’m not in front of my PC, but I remember that there is a panel to manage hide/unhide programs notifications, if I’m not wrong).

You’re not wrong, there’s a Notification page in Gnome Settings with switches for each of applications. It’s a new feature for Gnome 3.32, if I remember correctly.

1 Like

It seems to be solved (the notification popped up).
I’ll wait until there are system updates available.
Thank you, alciregi, for your cooperation!

Please note that the commands I suggested simply forced gnome-software to believe that the last check was performed 2 days ago, and the last update was performed 8 days ago. This in order to force a check in a short span of time.

The point is that I don’t know how Gnome Software handles updates checks. I mean, what is the interval of the check and the interval of the notifications? I read around that it checks for updates once a day, only if the network was online at logon, and the notification pops up once a week, and so on: but I found these information on some pretty old forum posts, so I don’t know if they are only suppositions and if they are still true. And they seem hard coded intervals (there is not an option to modify these intervals).

But I’m unable to find an official documentation.
Maybe somebody else here could point us to some GNOME doc or source code.

1 Like

The setting is called update preferences and there are 2 settings 1 is automatic updates which I have turned off and the other is automatic update notifications which I leave turned on.I leave my computer on most of the time and as far as I know it checks for updates once a day.When there is an update the notification pops up.I use the terminal to update so it’s nice to know when to update.