Gnome-terminal -e

Years past I would have a simple script to open a second terminal from the one I’m working in to start music. But for some reason the way I do it has a drepricated structure that kicks back instructions.
My simple script gnome-terminal -e “ogg123 /home/moopi/Music/playnow/”
Here are the instructions/objections:

[moopi@localhost ~]$ sh test2.sh 
# Option “-x” is deprecated and might be removed in a later version of gnome-terminal.
# Use “-- ” to terminate the options and put the command line to execute after it.
# _g_io_module_get_default: Found default implementation dconf (DConfSettingsBackend) for ‘gsettings-backend’
# watch_fast: "/org/gnome/desktop/interface/" (establishing: 0, active: 0)
# watch_fast: "/org/gnome/settings-daemon/peripherals/mouse/" (establishing: 0, active: 0)
# watch_fast: "/org/gnome/desktop/sound/" (establishing: 0, active: 0)
# watch_fast: "/org/gnome/desktop/privacy/" (establishing: 0, active: 0)
# watch_fast: "/org/gnome/desktop/wm/preferences/" (establishing: 0, active: 0)
# watch_fast: "/org/gnome/settings-daemon/plugins/xsettings/" (establishing: 0, active: 0)
# watch_fast: "/org/gnome/desktop/a11y/" (establishing: 0, active: 0)
# watch_established: "/org/gnome/desktop/interface/" (establishing: 1)
# watch_established: "/org/gnome/settings-daemon/peripherals/mouse/" (establishing: 1)
# watch_established: "/org/gnome/desktop/sound/" (establishing: 1)
# watch_established: "/org/gnome/desktop/privacy/" (establishing: 1)
# watch_established: "/org/gnome/desktop/wm/preferences/" (establishing: 1)
# watch_established: "/org/gnome/settings-daemon/plugins/xsettings/" (establishing: 1)
# watch_established: "/org/gnome/desktop/a11y/" (establishing: 1)
# _g_io_module_get_default: Found default implementation gvfs (GDaemonVfs) for ‘gio-vfs’
# watch_fast: "/org/gnome/terminal/legacy/" (establishing: 0, active: 0)
# unwatch_fast: "/org/gnome/terminal/legacy/" (active: 0, establishing: 1)
# watch_established: "/org/gnome/terminal/legacy/" (establishing: 0)

Is there a way to implement my command without the terminal objections to my method ?

1 Like

Although is says that some options are deprecated, there’s no replacement.

The verbose output is a bug.

Steps to reproduce:

gnome-terminal

Workaround:

gnome-terminal 2>/dev/null

You can report it here:

1 Like

Super , works great.

2 Likes

I thought -e was supposed to have been un-deprecated, since it’s still useful in various scenarios, and has no real replacement?

I guess looking at my bug again, removing the deprecation was discussed, but it never actually happened. ¯\_(ツ)_/¯

1 Like

I use this as a workaround:

gnome-terminal -q --tab -- /bin/sh -c 'my_command'

The -q removes the verbose output. Also, note the space between -- and /bin/sh.

1 Like

And I just use tmux.

Try:

gnome-terminal -- ogg123 /home/moopi/Music/playnow

In many cases -e/-x doesn’t have identical behavior to --, but I believe in this case it should.

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.