Grub customizer doesn't show all systems

Hi, I have problem with fedora 30. I have 3 systems installed Fedora 30, Windows 10 and Ubuntu, and when I turn on my computer Fedora boots first, giving me chance to choose the system. I would like to change their names and order, so I installed grub customizer. Problem is, that it listed only 2 positions: windows and system settings:


I’ve tried to update grub, but the message I get was:

Generating grub configuration file ...
device-mapper: remove ioctl on osprober-linux-sdb7  failed: Device or resource busy
Command failed.
Found Windows Boot Manager on /dev/sda1@/EFI/Microsoft/Boot/bootmgfw.efi
Adding boot menu entry for EFI firmware configuration
done

Could you help me make grub customizer see, what I see when I turn on my computer?

Fedora 30 switched to use the BLS format for configuring GRUB which AFAIK doesn’t work with GRUB Customizer. I don’t know of any workarounds.

3 Likes

This is not that hard to do by manually changing config files, if you’re up to it.

I won’t mess with Fedora’s entries, they are first by default and their names are set automatically. You can call Ubuntu and Windows entries anything you want, it’s easy. You can also set any entry you want to be booted by default, it doesn’t have to be the first one.

Please tell if you want to do it, I’ll provide some directions.

1 Like