Grub Dual Boot Issue: Win logo and then freeze

This behavior started with the the upgrade to kernel 5.18.13. I can boot normally into bootmgfw.efi via the bios. However, now via Grub I get the blue-boxes Win logo and it freezes.

### BEGIN /etc/grub.d/30_os-prober ###
menuentry 'Windows Boot Manager (on /dev/nvme0n1p1)' --class windows --class os
$menuentry_id_option 'osprober-efi-1341-9D26' {
    insmod part_gpt
    insmod fat
    search --no-floppy --fs-uuid --set=root 1341-9D26
    chainloader /EFI/Microsoft/Boot/bootmgfw.efi
}
# Other OS found, undo autohiding of menu unless menu_auto_hide=2
if [ "${orig_timeout_style}" -a "${menu_auto_hide}" != "2" ]; then
  set timeout_style=${orig_timeout_style}
  set timeout=${orig_timeout}
fi
### END /etc/grub.d/30_os-prober ###

Thoughts?

I run sudo grub2-mkconfig -o /boot/grub2/grub.cfg, but that hasn’t helped.

On my laptop the entry for windows reads

menuentry 'Windows Boot Manager (on /dev/nvme0n1p1)' --class windows --class os $menuentry_id_option 'osprober-efi-42F8-BF3E' {
	insmod part_gpt
	insmod fat
	if [ x$feature_platform_search_hint = xy ]; then
	  search --no-floppy --fs-uuid --set=root  42F8-BF3E
	else
	  search --no-floppy --fs-uuid --set=root 42F8-BF3E
	fi
	chainloader /EFI/Microsoft/Boot/bootmgfw.efi
}
# Other OS found, undo autohiding of menu unless menu_auto_hide=2
if [ "${orig_timeout_style}" -a "${menu_auto_hide}" != "2" ]; then
  set timeout_style=${orig_timeout_style}
  set timeout=${orig_timeout}
fi
### END /etc/grub.d/30_os-prober ###

I see the menuentry line is broken in two with what you posted. It must be a single line from menuentry through the {.

I also see an if - else - fi portion in mine that is missing from yours, though that is not likely to be the actual issue.

Try (after booting) deleting the /boot/grub2/grub.cfg file then repeat the sudo grub2-mkconfig -o /boot/grub2/grub.cfg command to see if it builds it properly that time.

If it still freezes after that then you may need to do a windows repair.

I’ve tried to delete and recreate grub.cfg. Did not help.

As to I do not understand, “you may need to do a windows repair.” As stated, bootmgfw.efi works great when booting from bios.

Please post the output of lsblk , ls /sys/firmware/efi and inxi -Fxz

$ ls /sys/firmware/efi
config_table efivars fw_platform_size fw_vendor runtime runtime-map systab

$ inxi -Fxz
System:
Kernel: 5.18.16-200.fc36.x86_64 arch: x86_64 bits: 64 compiler: gcc
v: 2.37-27.fc36 Desktop: GNOME v: 42.3.1
Distro: Fedora release 36 (Thirty Six)
Machine:
Type: Laptop System: Alienware product: Alienware Area-51m R2 v: 1.17.0
serial:
Mobo: Alienware model: Alienware Area-51m R2 v: A00
serial: UEFI: Alienware v: 1.17.0 date: 06/07/2022
Battery:
ID-1: BAT1 charge: 70.9 Wh (100.0%) condition: 70.9/90.0 Wh (78.8%)
volts: 12.5 min: 11.4 model: COMPAL PABAS0241231 status: full
CPU:
Info: 10-core model: Intel Core i9-10900K bits: 64 type: MT MCP
arch: Comet Lake rev: 5 cache: L1: 640 KiB L2: 2.5 MiB L3: 20 MiB
Speed (MHz): avg: 5103 high: 5115 min/max: 800/5300 cores: 1: 5092
2: 5107 3: 5101 4: 5096 5: 5102 6: 5107 7: 5115 8: 5105 9: 5109 10: 5095
11: 5114 12: 5110 13: 5102 14: 5109 15: 5102 16: 5100 17: 5105 18: 5100
19: 5101 20: 5099 bogomips: 147994
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
Graphics:
Device-1: Intel CometLake-S GT2 [UHD Graphics 630] vendor: Dell driver: N/A
arch: Gen9.5 bus-ID: 00:02.0
Device-2: NVIDIA TU104M [GeForce RTX 2080 SUPER Mobile / Max-Q]
vendor: Dell driver: nvidia v: 515.57 arch: Turing bus-ID: 01:00.0
Device-3: Realtek Integrated_Webcam_HD type: USB driver: uvcvideo
bus-ID: 1-7:3
Device-4: Tobii AB EyeChip type: USB driver: uvcvideo bus-ID: 1-9:4
Display: x11 server: X.Org v: 1.20.14 with: Xwayland v: 22.1.3 driver: X:
loaded: nvidia unloaded: fbdev,modesetting,nouveau,vesa
gpu: nvidia,nvidia-nvswitch resolution: 3840x2160~60Hz
OpenGL: renderer: NVIDIA GeForce RTX 2080 Super/PCIe/SSE2
v: 4.6.0 NVIDIA 515.57 direct render: Yes
Audio:
Device-1: Intel Comet Lake PCH cAVS vendor: Dell driver: snd_hda_intel
v: kernel bus-ID: 00:1f.3
Device-2: NVIDIA TU104 HD Audio vendor: Dell driver: snd_hda_intel
v: kernel bus-ID: 01:00.1
Sound Server-1: ALSA v: k5.18.16-200.fc36.x86_64 running: yes
Sound Server-2: PulseAudio v: 15.0 running: no
Sound Server-3: PipeWire v: 0.3.56 running: yes
Network:
Device-1: Intel Comet Lake PCH CNVi WiFi vendor: Rivet Networks
driver: iwlwifi v: kernel bus-ID: 00:14.3
IF: wlo1 state: up mac:
Device-2: Realtek Killer E3000 2.5GbE vendor: Dell driver: r8169
v: kernel port: 3000 bus-ID: 07:00.0
IF: enp7s0 state: down mac:
Bluetooth:
Device-1: Intel AX201 Bluetooth type: USB driver: btusb v: 0.8
bus-ID: 1-14:6
Report: rfkill ID: hci0 rfk-id: 0 state: down bt-service: enabled,running
rfk-block: hardware: no software: yes address: see --recommends
Drives:
Local Storage: total: 3.96 TiB used: 1.33 TiB (33.7%)
ID-1: /dev/nvme0n1 vendor: Samsung model: PM981a NVMe 2048GB
size: 1.86 TiB temp: 36.9 C
ID-2: /dev/nvme1n1 vendor: Samsung model: PM981a NVMe 2048GB
size: 1.86 TiB temp: 30.9 C
ID-3: /dev/sda type: USB vendor: Samsung model: Flash Drive FIT
size: 239.02 GiB
Partition:
ID-1: / size: 165.29 GiB used: 24.81 GiB (15.0%) fs: ext4
dev: /dev/nvme0n1p3
ID-2: /boot size: 973.4 MiB used: 228.6 MiB (23.5%) fs: ext4
dev: /dev/nvme0n1p2
ID-3: /boot/efi size: 497 MiB used: 412.5 MiB (83.0%) fs: vfat
dev: /dev/nvme0n1p1
ID-4: /home size: 1.48 TiB used: 234.04 GiB (15.4%) fs: ext4
dev: /dev/nvme0n1p4
Swap:
ID-1: swap-1 type: zram size: 8 GiB used: 0 KiB (0.0%) dev: /dev/zram0
Sensors:
System Temperatures: cpu: N/A mobo: N/A gpu: nvidia temp: 41 C
Fan Speeds (RPM): N/A
Info:
Processes: 406 Uptime: 7m Memory: 31.1 GiB used: 3.48 GiB (11.2%)
Init: systemd target: graphical (5) Compilers: gcc: 12.1.1 Packages: 27
note: see --pkg Shell: Bash v: 5.1.16 inxi: 3.3.19

I’m seeing a lot of similar reports. I can reproduce this too (even without using Bitlocker). See if they match your issue.

#278 Future of dual booting Windows and Fedora

I do have the TPM security chip. I have it turned off in the bios.

A recent grub update broke booting into Windows, see here:
https://bugzilla.redhat.com/show_bug.cgi?id=2115202

There’s an update available, please try it:
https://bodhi.fedoraproject.org/updates/FEDORA-2022-d0c322d15a

3 Likes

That works!