GRUB Menu NOT Showing

Hi guys,
I really checked on what to do to show the GRUB menu on my new laptop. Here is the content of my GRUB file. As I already tagged, this is Fedora 34. I need to access to the Windows menu but, GRUB menu does not show up as an entirety. I tried 2 things,

1)I tried holding onto SHIFT while starting up (Just found online somewhere about this solution but it did not do anything.)
2) Added “GRUB_TIMEOUT_STYLE=menu” line and run the 2 sudo commands

GRUB_TIMEOUT=5
GRUB_TIMEOUT_STYLE=menu
GRUB_DISTRIBUTOR="$(sed 's, release .*$,,g' /etc/system-release)"
GRUB_DEFAULT=saved
GRUB_DISABLE_SUBMENU=true
GRUB_TERMINAL_OUTPUT="console"
GRUB_CMDLINE_LINUX="resume=UUID=994ca378-ade8-452e-907d-749ca02f6eab rhgb quiet rd.driver.blacklist=nouveau"
GRUB_DISABLE_RECOVERY="true"
GRUB_ENABLE_BLSCFG=true

Then I ran the 2 commands:

sudo grub2-mkconfig -o /etc/grub2-efi.cfg
sudo grub2-mkconfig -o /boot/grub2/grub.cfg

But unfortunately GRUB menu don’t show up both on rebooting computer or booting up. Any help would be appreciated.

Does this work?

4 Likes

According to the FAQ:

If your system has Windows on it, but you boot it only once a year so you would still like to hide the GRUB menu, you can tell GRUB to ignore the presence of Windows by running:

sudo grub2-editenv - set menu_auto_hide=2

You can check if you have menu_auto_hide=2 set or not.

3 Likes

Omg I spent 3 hours beforehand and this one worked! Thank you!

Let’s say in future, if I want to hide it again, should I write,
sudo grub2-editenv - set menu_auto_hide
???

According to the FAQ:

2. How to enable hidden GRUB menu?

On new Fedora 29 Workstation installs this will be enabled by default. If your system has been upgraded to F29 from an older release, you can enable it by running these commands:

On a system using UEFI booting ( “ls /sys/firmware/efi/efivars” returns a bunch of files):

sudo grub2-editenv - set menu_auto_hide=1
sudo grub2-mkconfig -o /etc/grub2-efi.cfg

On a system using legacy BIOS boot:

sudo grub2-editenv - set menu_auto_hide=1
sudo grub2-mkconfig -o /etc/grub2.cfg