Grub still not showing up

Grub automatically boots after a second

here is my /etc/default/grub:

  GNU nano 5.6.1                  /etc/default/grub                             
GRUB_TIMEOUT=5
GRUB_TIMEOUT_STYLE=menu
GRUB_DISTRIBUTOR="$(sed 's, release .*$,,g' /etc/system-release)"
GRUB_SAVEDEFAULT="true"
GRUB_DISABLE_SUBMENU="false"
GRUB_TERMINAL_OUTPUT=console
GRUB_CMDLINE_LINUX="resume=UUID=c91d6048-0454-45ca-b764-76d675514da0 rhgb quiet>
GRUB_CMDLINE_LINUX_DEFAULT="rhgb quiet splash"
GRUB_DISABLE_RECOVERY=true
GRUB_ENABLE_BLSCFG=true

#GRUB_BACKGROUND= /usr/share/grub/backgrounds/background.png
export GRUB_COLOR_NORMAL=light-gray/black
export GRUB_COLOR_HIGHLIGHT=blue/black

here is my /boot/grub2/grubenv:

# GRUB Environment Block
# WARNING: Do not edit this file by tools other than grub-editenv!!!
save_default=true
boot_success=1
###############################################################################>

here is my /etc/grub.d/12_menu_auto_hide:

GNU nano 5.6.1                                                        /etc/grub.d/12_menu_auto_hide                                                                   
#!/usr/bin/sh
# Menu Auto Hide
#
# This snippet depends on 10_reset_boot_success and needs to be kept in sync.
#
# Disable / skip generating menu-auto-hide config parts on serial terminals
for x in ${GRUB_TERMINAL_INPUT} ${GRUB_TERMINAL_OUTPUT}; do
  case "$x" in
    serial*)
      exit 0
      ;;
  esac
done

cat << EOF
if [ x\$feature_timeout_style = xy ] ; then
  if [ "\${menu_show_once}" ]; then
    unset menu_show_once
    save_env menu_show_once
    set timeout_style=menu
    set timeout=60
  elif [ "\${menu_auto_hide}" -a "\${menu_hide_ok}" = "1" ]; then
    set orig_timeout_style=\${timeout_style}
    set orig_timeout=\${timeout}
    if [ "\${fastboot}" = "1" ]; then
      # timeout_style=menu + timeout=0 avoids the countdown code keypress check
      set timeout_style=menu
      set timeout=5
    else
      set timeout_style=menu
      set timeout=5
    fi
  fi
fi
EOF

I even tried this:sudo grub2-editenv - unset menu_auto_hide
Please help me display my grub on boot

1 Like

you could modify to

GRUB_TIMEOUT=55

just to verify that that indeed is the active setting file being active.
Clearly,

sudo grub2-editenv - unset menu_auto_hide

ought to not produce your result…

no luck :confused:

1 Like

to force visibility, as I wrote in my thread, u can always edit

 /etc/grub.d/12_menu_auto_hide

and put the variable

    set timeout_style=menu
    set timeout=5

right before the menu line additionally.

i.e. defeat the automatism. or whichever VARI / FILE it may be . it is just ‘’‘bash’’’ … so …

Thanks, would you please look at my, which I have already shared in my post

/etc/grub.d/12_menu_auto_hide

and point out where to add.
I kind of do not understand all these scripts and not that expert in Linux.

In my /etc/grub.d/12_menu_auto_hide file (which is the default, I didn’t make any changes to it), I have these lines which are different than yours and my grub menu shows up fine:

    if [ "\${fastboot}" = "1" ]; then
      # timeout_style=menu + timeout=0 avoids the countdown code keypress check
      set timeout_style=menu
      set timeout=0
    else
      set timeout_style=hidden
      set timeout=1
    fi

You can change those lines to match the above or you can get the default file by moving /etc/grub.d/12_menu_auto_hide file to somewhere else (i.e. your home dir) and reinstalling grub2-tools package with:

sudo dnf reinstall grub2-tools

After that, don’t forget to re-generate your grub config with grub2-mkconfig command.

Just for reference: The GNU GRUB manual can be found here: GNU GRUB Manual 2.04. That’s a perfect fit for online sharing of a special chapter.

For archiving, the PDF can be found here: GRUB - GNU Project - Free Software Foundation

1 Like

I have the same as you in my /etc/brub2/12_grub_menu_autohide and mine works properly.

The only thing I had to do after changing that file from default was to run the grub2-mkconfig command and the grub menu shows up with every boot. I did not have to change or do anything else.

I am running F33 and the same was the case with F32. Have not tried F34 yet.