Grub2 videoinfo not found

Hello there!

I got a new laptop with NVidia (:frowning_face:) graphics (I am not sure if this is important). However, I did a “clean” install (on a free space, along with Windows), and installed grub, however I am facing some weird issues.

Firstly, the grub menu is popping up in a low resolution (my screen is 1920*1080)
Secondly, on the grub command line, I try to execute videoinfo or vbeinfo or videotest and neither of these commands are found and an error is thrown.

Now, I tried setting the GRUB_GFXMODE and GRUB_GFXPAYLOAD_LINUX in /etc/default/grub and regenerated the config, however, I found that the config is installed in a weird location /boot/efi/EFI/fedora/grub.cfg, as compared to the usual /boot/grub/grub.cfg. The updated config does not affect the resolution.

Can anyone tell me what am I doing wrong here? Do I have to install some Nvidia driver (never had Nvidia, and am currently using the default Nouveau), or do I have to reinstall and fix grub?

Thanks for your help here… :smile:

When I started my journey with Fedora, the low resolution in GRUB bothered me terribly. Now when I don’t use dual boot, I don’t care. :grinning:

Fedora sets by default

GRUB_TERMINAL_OUTPUT="console"

in /etc/default/grub

Change it to GRUB_TERMINAL_OUTPUT="gfxterm"

Update GRUB. UEFI system:
grub2-mkconfig -o /boot/efi/EFI/fedora/grub.cfg

Non UEFI:
grub2-mkconfig -o /boot/grub2/grub.cfg

That should help.

2 Likes

To provide a bit more background to @roypen’s answer,

GRUB_TERMINAL_OUTPUT="console"

sets the grub menu to text-based console. I think this is done for compatibility reasons.

@major, all the commands and parameters you’ve tried are for graphical output of grub, they simply don’t work in console mode. They will in gfxterm mode.

Also just commenting out GRUB_TERMINAL_OUTPUT="console" will have the same effect: grub will use gfxterm mode – although providing the option explicitly is a cleaner solution.


One more thing I personally do to make grub menu more pleasant is install and activate grub theme. Install it with

sudo dnf install grub2-breeze-theme  

and then add to /etc/default/grub this line:

GRUB_THEME="/boot/grub2/themes/breeze/theme.txt"

and don’t forget to change mode to gfxterm, as suggested by @roypen. Regenerate grub.cfg menu – again, @roypen’s provided the commands to you – you need to do it after every change to /etc/default/grub.

The result won’t be astonishing, but it’ll be prettier than text console or default gfxterm output.

As far as I know, you can also find other themes for grub2 online – maybe prettier ones, – but they aren’t packaged in Fedora. Still they are easy to use if you want to.

2 Likes

Thanks a lot, @roypen and @nightromantic .

I removed all the extra variables, and just added the line GRUB_TERMINAL_OUTPUT="gfxterm".

It didn’t do anything, but as @nightromantic pointed out, I commented that line as well, and installed the breeze-theme. It did work, and somehow my grub is in good resolution now.

Thanks! :smile:

2 Likes

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.