GTK based apps swapping bold and non-bold fonts after upgrade to Fedora 31

After upgrading from Fedora 30 to Fedora 31 all GTK based apps, like Evolution and Workrave, use bold fonts were they previously used non-bold fonts, and vise-versa. I’m using KDE as my environment. I’ve tried re-applying the settings in System Settings > Application Style > GNOME/GTK Application Style and then restarting the apps, but this did nothing.

EDIT: It seems to have something to do with the sans-serif variant of DejaVu fonts, since if I use fontconfig to blacklist the DejaVu Sans family everything works fine.

EDIT 2: The problem goes away if apps are run under a brand new test user.

If your create a new test-user and log in, the problem persist?

Using a test-user makes the problem go away.

Then your have at least 2 choices:

  1. Delete (or temporarily move out) some configs inside of your old user directory.

  2. First, move your important data to the new user. Then, grant to the new user privileges (if your old one had them). Finally, delete the old user (preferably after week or two, just in case (if some important data was forgotten)!).

I figured it out: if the GTK font specified in ~/.config/gtk-3.0/settings.ini is a Window .FON file (font format Windows FNT) then all the weirdness happens. Since my computer dual boots with Windows 10 I also use the Windows fonts, and somehow a .FON font got selected. Selecting a more normal font type fixes the problem.

Don’t forget to mark your message above as the solution, so it will be displayed at the top!