Having low performance on 5700xt on fedora 33

I am having low performance on fedora with the 5700xt. For games the frame rates are about 1/3 lower than on windows. I recently reinstalled (preserving my home) and still keep having the same issue. I am running it on xorg and when I look at gpu usage it seems to be running at 100% when running those games.

I recently switched to an AMD gpu so I wouldn’t know if this was working on older kernels.

I get a blank screen without the amdgpu.drm=0 flag and not sure if that is some hint to the issue

any thoughts on the issue?

info dump:

#cat /proc/cmdline 
BOOT_IMAGE=(hd3,gpt2)/vmlinuz-5.9.11-200.fc33.x86_64 root=/dev/mapper/fedora_localhost--live-root ro resume=/dev/mapper/fedora_localhost--live-swap rd.lvm.lv=fedora_localhost-live/root rd.luks.uuid=luks-2d6c4309-0009-4df8-bd45-4a197bb1e3f8 rd.lvm.lv=fedora_localhost-live/swap rhgb quiet amdgpu.dpm=0 systemd.unified_cgroup_hierarchy=0

# uname -r
5.9.11-200.fc33.x86_64

# lsmod | grep amd 
edac_mce_amd           32768  0
kvm_amd               114688  0
kvm                   831488  1 kvm_amd
amdgpu               6430720  39
iommu_v2               20480  1 amdgpu
gpu_sched              40960  1 amdgpu
i2c_algo_bit           16384  2 igb,amdgpu
ttm                   122880  1 amdgpu
drm_kms_helper        266240  1 amdgpu
drm                   626688  18 gpu_sched,drm_kms_helper,amdgpu,ttm
ccp                   106496  1 kvm_amd
pinctrl_amd            32768  0

# rpm -qa | grep mesa                              
mesa-libgbm-20.2.3-1.fc33.x86_64
mesa-libglapi-20.2.3-1.fc33.x86_64
mesa-vulkan-drivers-20.2.3-1.fc33.x86_64
mesa-filesystem-20.2.3-1.fc33.x86_64
mesa-dri-drivers-20.2.3-1.fc33.x86_64
mesa-libGL-20.2.3-1.fc33.x86_64
mesa-libEGL-20.2.3-1.fc33.x86_64
mesa-libxatracker-20.2.3-1.fc33.x86_64
mesa-filesystem-20.2.3-1.fc33.i686
mesa-vulkan-drivers-20.2.3-1.fc33.i686
mesa-libglapi-20.2.3-1.fc33.i686
mesa-libGL-20.2.3-1.fc33.i686
mesa-dri-drivers-20.2.3-1.fc33.i686
# rpm -qa | grep amdgpu | sort
xorg-x11-drv-amdgpu-19.1.0-5.fc33.x86_64
# rpm -qa | grep vulkan | sort
mesa-vulkan-drivers-20.2.3-1.fc33.i686
mesa-vulkan-drivers-20.2.3-1.fc33.x86_64
vulkan-loader-1.2.148.1-1.fc33.i686
vulkan-loader-1.2.148.1-1.fc33.x86_64
# lspci -k | grep -EA3 'VGA|3D|Display'
0b:00.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Navi 10 [Radeon RX 5600 OEM/5600 XT / 5700/5700 XT] (rev c1)
	Subsystem: XFX Pine Group Inc. Device 5701
	Kernel driver in use: amdgpu
	Kernel modules: amdgpu

amdgpu.dpm=0 kernel parameter limits performance by disabling Dynamic Power Management (https://www.mikejonesey.co.uk/linux/amdgpu-linux-driver-parameters), so you need some other solution for blank screen problem.

radeontop shows some useful statistics, GPU clocks included - check them while playing a game to confirm cause of slower performance.

Upgrade your system, BIOS and try booting without amdgpu.dpm=0 (delete it in grub menu for temporary change). When does blank screen pop up? Can you switch to virtual terminal (e.g. Ctrl+Alt+F3)? Older x.Org logs and journalctl -b-1 (-1 means here last system boot, execute it as root or with sudo after rebooting from blank screen) should show some hints.
If that doesn’t help, a VBIOS update is another possibility (might be available with windows drivers).