Having Trouble Rebasing To 37 Beta

I am attempting to rebase from Fedora 36 Silverblue to the new 37 beta. I get the following message when I try:

Could not depsolve transaction; 1 problem detected:
 Problem: package firefox-langpacks-104.0.2-1.fc37.x86_64 requires firefox = 104.0.2-1.fc37, but none of the providers can be installed

On Reddit, it was suggested that I first remove firefox-langpacks using rpm-ostree override remove firefox-langpacks but it tells me that the package is not found. I have no layered packages, and have Firefox and gnome-software removed as base packages.

If I run rpm-ostree reset it restores both Firefox and gnome-software, and I am able to successfully deploy into the beta. But once booted into the beta I am unable to remove either firefox or gnome-software as base packages, getting the same error message as above.

I suspect that it is related to this change Releases/37/ChangeSet - Fedora Project Wiki

Maybe, in addition to firefox you should try to remove firefox-langpacks
rpm-ostree override remove firefox firefox-langpacks

If I run that command while booted in 36, I get the message that firefox langpacks is not found. So I ran rpm-ostree reset and then booted into the beta deployment. Then I run rpm-ostree override remove firefox firefox-langpacks gnome-software but Iā€™m getting the following:

Could not depsolve transaction; 1 problem detected:
 Problem: package gnome-software-rpm-ostree-43.rc-1.fc37.x86_64 requires libgnomesoftware.so.19()(64bit), but none of the providers can be installed
  - package gnome-software-rpm-ostree-43.rc-1.fc37.x86_64 requires gnome-software(x86-64) = 43.rc-1.fc37, but none of the providers can be installed
  - conflicting requests

Okay, after booting into the beta, I ran: rpm-ostree override remove firefox firefox-langpacks gnome-software gnome-software-rpm-ostree and it seems to have worked.

So for those with the same issue I did the following:

  1. rpm-ostree reset and reboot
  2. Rebase into beta 37 and boot into it
  3. rpm-ostree override remove firefox firefox-langpacks gnome-software gnome-software-rpm-ostree and reboot

Many thanks for the help

2 Likes