Headphones audio not working on Fedora 35

I just updated Fedora from version 34 to 35 and with the new version i noticed that the audio is directed to the “Line Out” output device of my creative sound card instead of the “Headphones” one (both of them are output devices of my Creative Sound Blaster Z audio card). The problem is that every time i turn on the pc, the system resets the default output device to “Headphones”.

https://www.imagebam.com/view/ME4S9XJ?full=1

https://www.imagebam.com/view/ME4S9XG?full=1

I also installed pavucontrol and in the “Output devices” tab i see that the program correctly detects whether the audio jack is inserted or not selecting the “Headphones” output device, so i think that “Headphones” should be the output device to use and not “Line Out”.

Is there a way to direct the audio to the “Heaphones” output device instead of the “Line Out” one? If not, how can i set up “Line Out” as the default audio device and avoid setting it manually each time i boot up the computer?

I already tried to set up alsamixer to the headphones settings but the problem remains.

Pleas try to update!

I had to switch the internal speaker manually to Headphones while plugin in a external speaker. Today while updating to Kernel 5.14.16-301.fc35.x86_64 I not had to select manually. It switched automatically.

Thanks for the answer. I updated the kernel today but the problem persists.

At this point i think the only solution is to use the onboard audio chip in order to avoid this problem.