Headset not working properly - Astro A20 - Newbie needs help

Hello,

I try to run my newly bought Headset “Astro A20”. The output device is recognised as “Analoge Ausgabe - Astro A20” but the input device is not recognised but when I touch the microphone (input device), I hear the sound of the microphone. If I try to test the output, the settings are frozen and I have to force to close the settings. I don’t know what to do…can somebody tell me what’s working wrong and what I could do to make the audio work properly?

Thanks for your help in advance; I’m going to read & reply again tomorrow because I’m from Germany and I’m very tired & it’s bed time now.

Kind Regards :heart:

P.S. I asked in the English forum because I hope that I can get more replies in here than elsewhere.

I tried to find something more useful. I found this:

https://fedoraproject.org/wiki/How_to_debug_sound_problems

Command 1: alsa-info.sh --no-upload

The log file is pretty long, what should I post out of it?

Command 2: sudo dnf remove alsa-plugins-pulseaudio

When I used the command, I log out and log back in after I’ve made this change. I started my VLC-Mediaplayer to test out if the sound would work. The music didn’t even start playing. Short after (when I tried to play the music again and again), pipewire unexpected shut down (pipewire killed by SIGSEGV; btw. after this shutdown, the music began to play but without sound). I clicked on the message, which informed me about the shutdown of pipewire and I let Fedora analyse the coredump. Now it’s saying that I should download 26 packages. I accepted this because declining it won’t bring me any further in this matter I guess.

I’m going to reply “to myself”/you all once “this progress” is over / gives me/you all more new material to work with.

Regards.

Welcome to the Fedoraproject @0udio1ystery
Your wiki article is quite old … fedora works now with pipewire and wireplumber.

To debug please do the following and post it here as pre-formatted </> text:

Hello @ilikelinux ,

thank you for your reply. I had no choice…I tried to find out the problem because I didn’t get a reply so far :grimacing: Xd.
Command 1: systemctl --user status “pipewire.*”

● pipewire.socket - PipeWire Multimedia System Socket
     Loaded: loaded (/usr/lib/systemd/user/pipewire.socket; enabled; preset: enabled)
     Active: active (running) since Thu 2023-01-19 16:07:38 CET; 3min 38s ago
      Until: Thu 2023-01-19 16:07:38 CET; 3min 38s ago
   Triggers: ● pipewire.service
     Listen: /run/user/1000/pipewire-0 (Stream)
     CGroup: /user.slice/user-1000.slice/user@1000.service/app.slice/pipewire.socket
Jan 19 16:07:38 fedora systemd[19412]: Listening on pipewire.socket - PipeWire Multimedia System Socket.
● pipewire.service - PipeWire Multimedia Service
     Loaded: loaded (/usr/lib/systemd/user/pipewire.service; disabled; preset: disabled)
    Drop-In: /usr/lib/systemd/user/pipewire.service.d
             └─00-uresourced.conf
     Active: active (running) since Thu 2023-01-19 16:07:41 CET; 3min 35s ago
TriggeredBy: ● pipewire.socket
   Main PID: 19644 (pipewire)
      Tasks: 2 (limit: 19122)
     Memory: 8.1M
        CPU: 199ms
     CGroup: /user.slice/user-1000.slice/user@1000.service/session.slice/pipewire.service
             └─19644 /usr/bin/pipewire
Jan 19 16:07:41 fedora systemd[19412]: Started pipewire.service - PipeWire Multimedia Service.
Jan 19 16:07:41 fedora pipewire[19644]: mod.rt: Can't find org.freedesktop.portal.Desktop. Is xdg-desktop-portal running?
Jan 19 16:07:41 fedora pipewire[19644]: mod.rt: found session bus but no portal
Jan 19 16:11:14 fedora pipewire[19644]: spa.alsa: set_hw_params: Timer expired
Jan 19 16:11:14 fedora pipewire[19644]: pw.node: (alsa_output.usb-Astro_Gaming_Astro_A20-00.analog-stereo-63) suspended -> error (Start error: Timer expired)

=> There’re errors.

Command 2: systemctl --user status “pipewire-pulse.*”

● pipewire-pulse.socket - PipeWire PulseAudio
     Loaded: loaded (/usr/lib/systemd/user/pipewire-pulse.socket; enabled; preset: enabled)
     Active: active (running) since Thu 2023-01-19 16:07:38 CET; 8min ago
      Until: Thu 2023-01-19 16:07:38 CET; 8min ago
   Triggers: ● pipewire-pulse.service
     Listen: /run/user/1000/pulse/native (Stream)
     CGroup: /user.slice/user-1000.slice/user@1000.service/app.slice/pipewire-pulse.socket
Jan 19 16:07:38 fedora systemd[19412]: Listening on pipewire-pulse.socket - PipeWire PulseAudio.
● pipewire-pulse.service - PipeWire PulseAudio
     Loaded: loaded (/usr/lib/systemd/user/pipewire-pulse.service; disabled; preset: disabled)
     Active: active (running) since Thu 2023-01-19 16:07:42 CET; 8min ago
TriggeredBy: ● pipewire-pulse.socket
   Main PID: 19724 (pipewire-pulse)
      Tasks: 2 (limit: 19122)
     Memory: 13.6M
        CPU: 175ms
     CGroup: /user.slice/user-1000.slice/user@1000.service/session.slice/pipewire-pulse.service
             └─19724 /usr/bin/pipewire-pulse
Jan 19 16:07:42 fedora systemd[19412]: Started pipewire-pulse.service - PipeWire PulseAudio.
Jan 19 16:07:42 fedora pipewire-pulse[19724]: mod.rt: Can't find org.freedesktop.portal.Desktop. Is xdg-desktop-portal running?
Jan 19 16:07:42 fedora pipewire-pulse[19724]: mod.rt: found session bus but no portal

=> Looks like no errors?

Command 3: systemctl --user status wireplumber

● wireplumber.service - Multimedia Service Session Manager
     Loaded: loaded (/usr/lib/systemd/user/wireplumber.service; enabled; preset: enabled)
     Active: active (running) since Thu 2023-01-19 16:07:41 CET; 5min ago
   Main PID: 19645 (wireplumber)
      Tasks: 4 (limit: 19122)
     Memory: 5.9M
        CPU: 779ms
     CGroup: /user.slice/user-1000.slice/user@1000.service/session.slice/wireplumber.service
             └─19645 /usr/bin/wireplumber
Jan 19 16:07:41 fedora systemd[19412]: Started wireplumber.service - Multimedia Service Session Manager.
Jan 19 16:07:41 fedora wireplumber[19645]: Can't find org.freedesktop.portal.Desktop. Is xdg-desktop-portal running?
Jan 19 16:07:41 fedora wireplumber[19645]: found session bus but no portal
Jan 19 16:07:41 fedora wireplumber[19645]: Failed to set scheduler settings: Operation not permitted
Jan 19 16:07:41 fedora wireplumber[19645]: SPA handle 'api.libcamera.enum.manager' could not be loaded; is it installed?
Jan 19 16:07:41 fedora wireplumber[19645]: PipeWire's libcamera SPA missing or broken. libcamera not supported.
Jan 19 16:07:41 fedora wireplumber[19645]: GetManagedObjects() failed: org.freedesktop.DBus.Error.NameHasNoOwner
Jan 19 16:07:42 fedora wireplumber[19645]: <WpPortalPermissionStorePlugin:0x55f84b3ecce0> Failed to call Lookup: GDBus.Error:org.freedesktop.portal.Error.NotFound: No entry for camera

=> There’re errors.

I also just wanted to say I also posted the filed bug to bugzilla.redhat.com (maybe it also helps).

2143727 – [abrt] pipewire-pulseaudio: core_sync.isra.0(): pipewire-pulse killed by SIGSEGV

Please use LANG=C systemctl --user status “pipewire.*”

My mother tongue is German but a lot of users do not read/write German.

If you post code use the </> button instead the quote one.
thx

I’ve updated the thread @ilikelinux .

Hello again,

I began to read the log files a bit. I’ve found out, that in every log file is asked if the service “xdg-desktop-portal” is running. I checked that - if it’s running - out.
Command: systemctl --user xdg-desktop-portal.service

● xdg-desktop-portal.service - Portal service
     Loaded: loaded (/usr/lib/systemd/user/xdg-desktop-portal.service; static)
     Active: active (running) since Thu 2023-01-19 17:02:01 CET; 53min ago
   Main PID: 2444 (xdg-desktop-por)
      Tasks: 6 (limit: 19122)
     Memory: 4.0M
        CPU: 154ms
     CGroup: /user.slice/user-1000.slice/user@1000.service/session.slice/xdg-desktop-portal.service
             └─2444 /usr/libexec/xdg-desktop-portal
Jan 19 17:02:00 fedora systemd[1803]: Starting xdg-desktop-portal.service - Portal service...
Jan 19 17:02:01 fedora systemd[1803]: Started xdg-desktop-portal.service - Portal service.

=> It’s running. That means, something else must be wrong.

Hello @ilikelinux ,

I just wanted to say, that I’m still interested in a solution. I’m not gone.

Regards!

P.S. I have the feeling, that I didn’t execute the commands as they should have been executed? But if I copy & paste & execute e.g. “systemctl --user status “pipewire.*” if pipewire socket and service active (running) = ok.”, I’m getting a syntax error…

That command would be exactly systemctl --user status pipewire.*.
Using copy&paste might get you the wrong syntax if you copy a character that should not be there or miss a character that is needed.
You posted “systemctl --user status “pipewire.*” which at best has an extra " in the text.
@ilikelinux suggested LANG=C systemctl --user status “pipewire.*” which also should work.

Okay.

Btw. I’m currently using another (functioning) audio device (soundbar).
I’ve used all the command again with this functioning audio device. Maybe comparing this output helps in some way (e.g. what can’t be the problem (?) because the functioning audio device is working even with these problems):

Command 1: systemctl --user status “pipewire.*”

● pipewire.socket - PipeWire Multimedia System Socket
     Loaded: loaded (/usr/lib/systemd/user/pipewire.socket; enabled; preset: enabled)
     Active: active (running) since Mon 2023-01-23 15:54:10 CET; 28min ago
      Until: Mon 2023-01-23 15:54:10 CET; 28min ago
   Triggers: ● pipewire.service
     Listen: /run/user/1000/pipewire-0 (Stream)
     CGroup: /user.slice/user-1000.slice/user@1000.service/app.slice/pipewire.socket
Jan 23 15:54:10 fedora systemd[1817]: Listening on pipewire.socket - PipeWire Multimedia System Socket.
● pipewire.service - PipeWire Multimedia Service
     Loaded: loaded (/usr/lib/systemd/user/pipewire.service; disabled; preset: disabled)
    Drop-In: /usr/lib/systemd/user/pipewire.service.d
             └─00-uresourced.conf
     Active: active (running) since Mon 2023-01-23 15:54:14 CET; 28min ago
TriggeredBy: ● pipewire.socket
   Main PID: 2038 (pipewire)
      Tasks: 2 (limit: 19122)
     Memory: 7.4M
        CPU: 2.907s
     CGroup: /user.slice/user-1000.slice/user@1000.service/session.slice/pipewire.service
             └─2038 /usr/bin/pipewire
Jan 23 15:54:14 fedora systemd[1817]: Started pipewire.service - PipeWire Multimedia Service.
Jan 23 15:54:14 fedora pipewire[2038]: mod.rt: Can't find org.freedesktop.portal.Desktop. Is xdg-desktop-portal running?
Jan 23 15:54:14 fedora pipewire[2038]: mod.rt: found session bus but no portal

Command 2: systemctl --user status “pipewire-pulse.*”

● pipewire-pulse.service - PipeWire PulseAudio
     Loaded: loaded (/usr/lib/systemd/user/pipewire-pulse.service; disabled; preset: disabled)
     Active: active (running) since Mon 2023-01-23 15:54:15 CET; 29min ago
TriggeredBy: ● pipewire-pulse.socket
   Main PID: 2117 (pipewire-pulse)
      Tasks: 2 (limit: 19122)
     Memory: 21.8M
        CPU: 5.723s
     CGroup: /user.slice/user-1000.slice/user@1000.service/session.slice/pipewire-pulse.service
             └─2117 /usr/bin/pipewire-pulse
Jan 23 15:54:15 fedora systemd[1817]: Started pipewire-pulse.service - PipeWire PulseAudio.
Jan 23 15:54:15 fedora pipewire-pulse[2117]: mod.rt: Can't find org.freedesktop.portal.Desktop. Is xdg-desktop-portal running?
Jan 23 15:54:15 fedora pipewire-pulse[2117]: mod.rt: found session bus but no portal
● pipewire-pulse.socket - PipeWire PulseAudio
     Loaded: loaded (/usr/lib/systemd/user/pipewire-pulse.socket; enabled; preset: enabled)
     Active: active (running) since Mon 2023-01-23 15:54:10 CET; 29min ago
      Until: Mon 2023-01-23 15:54:10 CET; 29min ago
   Triggers: ● pipewire-pulse.service
     Listen: /run/user/1000/pulse/native (Stream)
     CGroup: /user.slice/user-1000.slice/user@1000.service/app.slice/pipewire-pulse.socket
Jan 23 15:54:10 fedora systemd[1817]: Listening on pipewire-pulse.socket - PipeWire PulseAudio.

Command 3: systemctl --user status wireplumber

● wireplumber.service - Multimedia Service Session Manager
     Loaded: loaded (/usr/lib/systemd/user/wireplumber.service; enabled; preset: enabled)
     Active: active (running) since Mon 2023-01-23 15:54:14 CET; 30min ago
   Main PID: 2039 (wireplumber)
      Tasks: 4 (limit: 19122)
     Memory: 6.2M
        CPU: 1.093s
     CGroup: /user.slice/user-1000.slice/user@1000.service/session.slice/wireplumber.service
             └─2039 /usr/bin/wireplumber
Jan 23 15:54:14 fedora systemd[1817]: Started wireplumber.service - Multimedia Service Session Manager.
Jan 23 15:54:14 fedora wireplumber[2039]: Can't find org.freedesktop.portal.Desktop. Is xdg-desktop-portal running?
Jan 23 15:54:14 fedora wireplumber[2039]: found session bus but no portal
Jan 23 15:54:14 fedora wireplumber[2039]: Failed to set scheduler settings: Operation not permitted
Jan 23 15:54:14 fedora wireplumber[2039]: SPA handle 'api.libcamera.enum.manager' could not be loaded; is it installed?
Jan 23 15:54:14 fedora wireplumber[2039]: PipeWire's libcamera SPA missing or broken. libcamera not supported.
Jan 23 15:54:14 fedora wireplumber[2039]: GetManagedObjects() failed: org.freedesktop.DBus.Error.NameHasNoOwner
Jan 23 15:54:15 fedora wireplumber[2039]: <WpPortalPermissionStorePlugin:0x55c2cf4169c0> Failed to call Lookup: GDBus.Error:org.freedesktop.portal.Error.NotFound: No entry for camera

It seems to be a problem with this “alsa-thing”?

I just noticed…that my bluetooth is not even on…but doesn’t the Astro A20 uses Bluetooth for the wireless connection (?)…but that makes non-sense because I can hear the microphone working…I’m confused. Anyway, I wasn’t able to find drivers, which are for linux. My mainboard is also pretty old. Anyway, I searched for the bluetooth problem and I’ve found this thread here…and executed one command out of it so far…maybe this information helps you:

Command 1: inxi -Fzx

System:
  Kernel: 6.1.6-200.fc37.x86_64 arch: x86_64 bits: 64 compiler: gcc
    v: 2.38-25.fc37 Desktop: GNOME v: 43.2 Distro: Fedora release 37 (Thirty
    Seven)
Machine:
  Type: Desktop Mobo: ASUSTeK model: M5A78L-M/USB3 v: Rev X.0x
    serial: <superuser required> BIOS: American Megatrends v: 2101
    date: 12/02/2014
CPU:
  Info: 8-core model: AMD FX-8350 bits: 64 type: MT MCP arch: Piledriver
    rev: 0 cache: L1: 384 KiB L2: 8 MiB L3: 8 MiB
  Speed (MHz): avg: 1459 high: 1670 min/max: 1400/4000 boost: enabled cores:
    1: 1406 2: 1580 3: 1406 4: 1406 5: 1404 6: 1670 7: 1404 8: 1400
    bogomips: 64284
  Flags: avx ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
Graphics:
  Device-1: NVIDIA GM204 [GeForce GTX 970] vendor: eVga.com. driver: nvidia
    v: 525.78.01 arch: Maxwell bus-ID: 01:00.0
  Device-2: Logitech HD Pro Webcam C920 type: USB
    driver: snd-usb-audio,uvcvideo bus-ID: 1-6:4
  Display: x11 server: X.Org v: 1.20.14 with: Xwayland v: 22.1.7 driver: X:
    loaded: nvidia unloaded: fbdev,modesetting,nouveau,vesa
    gpu: nvidia,nvidia-nvswitch resolution: 1920x1080
  API: OpenGL v: 4.6.0 NVIDIA 525.78.01 renderer: NVIDIA GeForce GTX
    970/PCIe/SSE2 direct render: Yes
Audio:
  Device-1: AMD SBx00 Azalia vendor: ASUSTeK M4A785TD driver: snd_hda_intel
    bus-ID: 1-6:4 v: kernel bus-ID: 00:14.2
  Device-2: NVIDIA GM204 High Definition Audio vendor: eVga.com.
    driver: snd_hda_intel v: kernel bus-ID: 01:00.1
  Device-3: Logitech HD Pro Webcam C920 type: USB
    driver: snd-usb-audio,uvcvideo
  Sound API: ALSA v: k6.1.6-200.fc37.x86_64 running: yes
  Sound Server-1: PulseAudio v: 16.1 running: no
  Sound Server-2: PipeWire v: 0.3.64 running: yes
Network:
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
    vendor: ASUSTeK P8 series driver: r8169 v: kernel port: e800 bus-ID: 03:00.0
  IF: enp3s0 state: up speed: 100 Mbps duplex: full mac: <filter>
Drives:
  Local Storage: total: 2.51 TiB used: 1.1 TiB (43.7%)
  ID-1: /dev/sda vendor: Samsung model: SSD 850 PRO 128GB size: 119.24 GiB
  ID-2: /dev/sdb vendor: Samsung model: SSD 850 PRO 128GB size: 119.24 GiB
  ID-3: /dev/sdc vendor: Crucial model: CT500MX500SSD1 size: 465.76 GiB
  ID-4: /dev/sdd type: USB vendor: Seagate model: Expansion size: 931.51 GiB
  ID-5: /dev/sde type: USB vendor: Seagate model: Expansion+
    size: 931.51 GiB
Partition:
  ID-1: / size: 118.24 GiB used: 62.4 GiB (52.8%) fs: btrfs dev: /dev/sda2
  ID-2: /boot size: 973.4 MiB used: 293.1 MiB (30.1%) fs: ext4
    dev: /dev/sda1
  ID-3: /home size: 118.24 GiB used: 62.4 GiB (52.8%) fs: btrfs
    dev: /dev/sda2
Swap:
  ID-1: swap-1 type: zram size: 8 GiB used: 0 KiB (0.0%) dev: /dev/zram0
Sensors:
  System Temperatures: cpu: 36.0 C mobo: 32.0 C gpu: nvidia temp: 62 C
  Fan Speeds (RPM): cpu: 917 case-1: 0 gpu: nvidia fan: 3%
  Power: 12v: 11.87 5v: N/A 3.3v: 3.34 vbat: N/A
Info:
  Processes: 753 Uptime: 55m Memory: 15.6 GiB used: 3.75 GiB (24.0%)
  Init: systemd target: graphical (5) Compilers: gcc: 12.2.1 Packages: 38
  note: see --rpm Shell: Bash v: 5.2.15 inxi: 3.3.24

Did I just find the problem…? I’m really not sure.

No, I didn’t find the problem. I’ve asked an online friend…via Discord…and the words were, that it probably has something to do with pipewire n’ less with my bluetooth driver.

Hi, is this your headset?

If so, it does not use Bluetooth. The USB dongle is a Logitech-specific wireless thing.

Can you identify the specific model of your Astro A20? It seems there are different generations and PS4 / Xbox variants, which might be relevant. Click the A20 button under “Family” on this page.


The following command will upload the output of alsa-info.sh and pactl list to the Fedora pastebin:

$ (alsa-info.sh --stdout; pactl list) | fpaste

Please run this and reply with the URL it gives you.

1 Like

Hello @jn64 ,

yes it is this newer generation (Gen2) of the Astro A20 (PC & Playstation Version). Some hours ago, I also found something in the news of pipewire (pipewire/NEWS at master · PipeWire/pipewire · GitHub):

PipeWire 0.3.64 (2023-01-12)

SPA

- Add support for Astro A20 Gen2.

Around this time of search, I’ve also received some updates for pipewire BUT the headset isn’t working yet (and it’s also not shown anymore). The online friend told me, that it might take some more time because the drivers have to be tested because they’re Arch devs.

Anyway, I executed the Command and here’s the output:
https://paste.centos.org/view/34fac3dc

Thanks for your time/help in advance.

Reading there I could imagine that the System has problems about the two mics you have. Or is there a onboard mic available too?

I Guess your Webcam has a microphone too? right?

Assuming, as long you are not switching it permanent off or configure it manually it will always interfere with the one from the headset.

PipeWire 0.3.64 is already in Fedora 37 since ~10 days ago. Can you check your version and update if necessary? You are on PipeWire 0.3.64 according to your logs.

Though it seems like your headset has a different ID than expected. This is yours:

Bus 005 Device 002: ID 9886:0047 Astro Gaming Astro A20

The rule in /usr/lib/udev/rules.d/90-pipewire-alsa.rules:

# ID 9886:0045 is for the Astro A20 Gen2
ATTRS{idVendor}=="9886", ATTRS{idProduct}=="0045", ENV{ACP_PROFILE_SET}="usb-gaming-headset.conf"

So, let’s try to add a custom udev rule for your device ID.

We need to create a file in /etc/udev/rules.d/ as root, with the above rule modified with your ID. Here is a single command that will do it; you can copy and paste the following code block including newlines into your terminal:

cat <<EOF | sudo tee /etc/udev/rules.d/99-astro-a20.rules
# ID 9886:0047 is for the Astro A20 Gen2
ATTRS{idVendor}=="9886", ATTRS{idProduct}=="0047", ENV{ACP_PROFILE_SET}="usb-gaming-headset.conf"
EOF

After pasting it press enter. Then, check that the rule is in place with:

$ sudo systemd-analyze cat-config udev/rules.d | grep 9886

You should see both the original 0045 and your added 0047 lines.

I’m not sure if you need to restart pipewire or even your user session, or simply disconnect and reconnect the Astro’s USB dongle. If in doubt, just reboot.

Then, run pavucontrol, and on the Configuration tab, you should now have various profiles available for the A20. Let’s try to get to this point first before we figure out the rest.

Hey @jn64 ,

I’m going to do all these steps tomorrow because it’s later over here. Thank you for your help so far.

Cya :slight_smile:

Hello @ilikelinux ,

I’m going to try out that first, which @jn64 recently posted after your reply. Afterwards, I’m going to try out the same without camera (except it’s still working). Why? I was able to switch (before the updates) to the A20 Adapter (in the audio settings [the GUI]). After the update, I wasn’t anymore.

I hope that’s okay for you BUT thanks for the remind; as I said, I’m also going to test that out because that might be useful for me or others - also, a good documentation of the process to fix the A20 would be probably nice to read for people, who’re facing similar problems!

Kind Regards :slight_smile:

P.S. Yes, the C920 from Logitech also has a microphone but I deactivated it over the GUI and it wasn’t making problems when I’ve used the G430 from Logitech.

Hello @jn64 ,

so. First of all I’ve created a new log-file because I was so dumb to plug out my cam first. Only thing that changed was the device, it’s “Device 006” now. To make sure, here is the link to this newly created log-file: https://paste.centos.org/view/d6ea0fff

So. As far as I understood you about the IDs, the ID 0045 is the standard ID which is not working for me. That’s why I need the custom rule (which is just the same, except that the ID is different) & that all the changes happen in the for this purpose (custom ID) specified directory.

I switched to the directory via the GUI and I opened a terminal there and used:

sudo nano 99-astro-a20.rules

I hope it’s alright…because I wasn’t sure if I had to backslash the command >lines< to completely execute the command e.g. like this:

cat <<EOF | sudo tee /etc/udev/rules.d/99-astro-a20.rules \
...a command line... \
...another command lines... \

Aside of that little preference problem: I see the added custom rule. The output of the command (sudo systemd) looks like this:

# ID 9886:002c is for the Astro A50 Gen4
ATTRS{idVendor}=="9886", ATTRS{idProduct}=="002c", ENV{ACP_PROFILE_SET}="usb-gaming-headset.conf"
# ID 9886:0045 is for the Astro A20 Gen2
ATTRS{idVendor}=="9886", ATTRS{idProduct}=="0045", ENV{ACP_PROFILE_SET}="usb-gaming-headset.conf"
# ID 9886:0047 is for the Astro A20 Gen2 //COMMENT FROM ME: HERE IS IT!
ATTRS{idVendor}=="9886", ATTRS{idProduct}=="0047", ENV{ACP_PROFILE_SET}="usb-gaming-headset.conf"

I’m going to edit this thread, once I’ve restarted my computer. The edit will be underneath this message.

I’m back. So. The headset is still not visible in the audio settings. Now, I’m going to remove my camera, restart the computer, use another usb port and check it again…