Help! Fedora just randomly deleted hours of my work and bricked itself all on its own

I saw that you already got to the terminal, cut I’d like to suggest just adding the numeral 3 to the end of GRUB’s linux line so the system will boot to the runlevel 3 and remove the quiet option for verbosity.
Do you still have your live media? It would this easier for you.

Also I recommend when you solve your issues to take a look at btrbk:

https://wiki.gentoo.org/wiki/Btrbk

I’m using it for backups and snapshots on my drive and external USB 3.x. I already used it for restoring data. Including “rolling back” from Fedora 36 beta to Fedora 35, for example. I have a much simpler sub volume structure (/root and /home) and don’t mind using it via command line.
I tried snapper with and without OpenSuse partitioning scheme and timeshift.

1 Like

I know that my reply is slightly out of the topic, but still.
I’m aware that many users are using BTRFS successfully to this day and there are cases of badly failed Fedora installs with BTRFS. I’m one of those with bad luck - my FW install went bananas after forced hard reset. I wasn’t able to get my files back regardless help I got in forums. Not super important ones for which I had working backup, but, still annoying. I learned the lesson and from now on I install Fedora using Fedora’s recommended partitions formatted with EXT4. EXT4 worked for me stable as rock before and still working now even if the install is more involving. I can wait until BTRFS gets as mature as EXT4 is.

4 Likes

literally no live linux live usbs would boot, this is why i told people over and over when they wouldn’t stop suggesting this like it was a 'solution even though it clearly was just dodging the actualy problem and wasnt going to work anyway

how many more times did i have to say it? but apparently ppl here just dont listen because nobody wants to admit thats a problem too i guess

it doesnt matter now, i got sacked and they confiscated the entire laptop too

ive spent the whole week arguing with them, i told them it was illegal because im a under contract and its my laptop, they just kept saying it was for ‘data security’ even though its literally just hardware and furniture stock. police wouldnt do anything, ‘civil matter’

finally got it back today and they wiped the whole ssd and lost a bunch of the case screws. when i told the it guys i was using linux they just laughed in my face so i guess the jokes on me

so i have no job now im literally totally broke and i have rent this week and can’t even sell it because they messed up the case and it wont even read the ssd in bios now so im totally stuffed.

lesson learned, linux is a mess and theres no way to get help when it breaks, everyone just dumps on you more

1 Like

I’m sorry for that, i must have forgotten by the time I’ve decided to write that comment, it’s a really long thread…

Have you checked the ssd is physically there? it may have been installed incorectly, if they took it out to erase it.

To be fair, if you decide to maintain anything entirely by yourself, you are expected to learn stuff, which inevitably results in breaking stuff sometimes too…

If you are in position where you can’t afford that, I would always recommend to use distributions with paid support and or find someone in your proximity, that could help with troubleshooting and or maintaining such system for you on-site. And that is true not only for linux, but for anything you want to use for mission critical applications. Public forums are never suited for this as they can’t replace direct support, unfortunatelly.

I’m realy sorry this ended up such way for you and I hope you will be able to sort things out soon.

4 Likes