Help to learn about fine tuning sharing my mouse with a vm

I have a WIndows 10 vm that is using GPU-Passthrough (really it is PCI-passthrough). i have already tested it with a graphically intensive application, and it works fine. BUT the mouse behavior is absolutely not acceptable. I have minimal dexterity. Changing the mouse sensitivity setting in the vm OS do not affect the movement, nor do the settings in an application. What is worse is that I cannot cause the vm OS to “grab” the pointer which leaves me struggling as the pinter will leave the vm context and thus fouls up whatever drag/drop operation I was attempting. The mouse/keyboard setup is essentially vinalla for F35, as far as I can tell.

I don’t think SPICE can help me, since I decided I needed GPU acceleration, because installing those tools gets rid of the pointer control altogether.

In short, I need either very good guidance in how to make this work properly. OR advice as to where to start learning about how to configure this manually.

Any helpful advice would be greatly appreciated.

You could open the VM window in a different workspace and make it full screen which would then avoid the mouse moving outside the window. Fedora has by default 2 workspaces defined when first started and if left with the default config it can add more as needed.

Maybe a good short-term work-around. But there is a window which holds the terminal, if I maximize that then I have one whole monitor which is unusable on the host. And I have already given up another monitor to the independent GPU… That is not a long term solution. But thank you for the suggestion.

Not quite. A workspace is a virtual screen and is seen as accessible when you open up the activities menu like this.


Notice at the far right the beginning of another background image. Clicking on that will give you a completely blank desktop image in another workspace where you can do things without bothering or being bothered by what is in the first workspace.

Also, if you have installed the gnome-extensions-app package then open up the extensions app, at the bottom you can find one entry where you can enable a windows list at the bottom of your screen that shows all open windows and at the far right will show all currently available workspaces. Clicking on the workspace there will switch the workspaces as well.

The next image shows the second workspace on my system where I have opened a VM to full screen. At the lower right you can see indicated the second workspace that is active.
The image after that is of the main workspace and again you can see the first workspace indicated as active in the lower right corner.
This is one PC, using one monitor, and currently with 2 workspaces active that can be selected with a simple mouse click.

Ok, I can see how that would help keep things tidier. Still just a temporary work-around on my machine; I will probably do that until I figure out a proper fix. Thanks for the advice!

Ok. So evdev was the solution to my problem. I guess I cheated a little bit since I used the following helper script:

It also has a link to a video showing how to use it.

There’s also a helpful article here:

There was a slight amount of troubleshooting. When I left or right clicked anywhere on the screen the pointer would be moved to a fixed point, every time. It seemed that the mouse I am using has a second interface, and removing the two lines associated with the keyboard interface form that mouse fixed the problem.