Hibernate not working properly

I have been trying to enable hibernate on my Fedora system and have done some steps that I’ve seen online. I’ve made a swap partition (10gb, I have 8gb of RAM), disabled secure boot, and added a boot parameter to grub.cfg and rebuilt it. But when I try to hibernate and boot the computer back up, the computer boots up as if it was starting up normally with no hibernation. Any ideas on how to solve this issue?

Two things:

  • In recent versions of Fedora you may need to use grubby to add kernel options to grub.
  • What kernel options did you add specifically?

I added the parameter “resume=UUID=(UUID of swap partition)” to GRUB CMDLINE LINUX in grub.cfg. Hibernate now appears as a power off option in my KDE start menu, but does a normal shutdown. I enabled the swap partition with swapon as well.

Try using grubby to make that change as described in the link above.

Just ran this on my machine: sudo grubby --args=“resume=UUID=(UUID of swap partition)” --update-kernel /boot/vmlinuz-5.15.5-200.fc35.x86_64

The output of sudo grubby --info /boot/vmlinuz-5.15.5-200.fc35.x86_64 is:

index=0
kernel="/boot/vmlinuz-5.15.5-200.fc35.x86_64"
args=“ro rootflags=subvol=root rhgb quiet resume=UUID=436f3950-8bf7-4e6d-ba2e-1921ec64e633”
root=“UUID=a55ca70a-7efd-486d-be81-1ccd8f6ee9d7”
initrd="/boot/initramfs-5.15.5-200.fc35.x86_64.img"
title=“Fedora Linux (5.15.5-200.fc35.x86_64) 35 (Workstation Edition)”
id=“9dc13be37f434cb092e744c7a2ecc333-5.15.5-200.fc35.x86_64”

Tested hibernate again, and it did the same thing with starting up normally.

Did the resume parameter get added to the initramfs?

ref: How to enable hibernation on Fedora

1 Like

This actually worked! I didn’t add resume to the initramfs and didn’t edit /etc/systemd/sleep.conf. After doing both those steps, my system hibernated properly and booted up as fast as I thought it would from it (~10 seconds), and all my apps were still open, just as I left them. Thanks so much for the help!

2 Likes