Hibernation does not working in KDE Spin

The hibernation option simply does not work and never worked for me personally. I suspect it might be related to some bad configuration in the KDE Spin.

I have also tried all 3 hibernation modes from this troubleshooting guide but none of them worked, my system just starts normally in all cases.

I have 8 GB RAM and a 16 GB Swap partition (which is the recommended amount according to the installation guide)

Any ideas as to what can fix this issue? Thank you for the help in advance! :smile:

P.S I am still on Fedora 30 if that matters.

Is that guide really from 2007? It’s very outdated if so.

I’m on the KDE spin as well and hibernation has worked for me since Fedora 27. IIRC the fix was something like this: https://openterprise.it/2019/09/enable-hibernation-on-fedora-linux/

At the time I believe it required editing /boot/grub/grub.cfg directly, but that file doesn’t seem to exist on Fedora 31. There is a /etc/default/grub file though with kernel command line options corresponding to those in my /boot/efi/EFI/fedora/grub.cfg, so I’d recommend editing that file if you have it.

1 Like

Thanks for the reply.

Is that guide really from 2007? It’s very outdated if so.

Yes, but I doubt it is outdated as it is still up and hosted in the offical website of the Linux kernel (I think).

I had a look at the documentation for the resume kernel parameter (which is also what is mentioned in the link that you mentioned) and decided to edit the defaults in /etc/default/grub file to include it along with the UUID of my swap partition, now it looks something like this (only the GRUB_CMDLINE_LINUX variable):

GRUB_CMDLINE_LINUX="resume=UUID=e5f1f037-0eee-4c48-8be6-d4e098163695 rhgb quiet"

You can find the UUID of your swap partition using a program like GNOME Disks.

Don’t forget to regenerate your grub configuration after you finish editing the defaults, I borrowed these commands from the link in the previous post which will do that for you:

For BIOS computers: sudo grub2-mkconfig -o /boot/grub2/grub.cfg
For UEFI computers: sudo grub2-mkconfig -o /boot/efi/EFI/fedora/grub.cfg

I just tested it and it works! Even though waking up from hibernation is slow, and each application is a bit clucky after hibernation and it takes some time for it to become normal. Not a big issue, at-least it is working now :grin:

1 Like