Higher resolution for tty1-6 and at boot, strange problem

Hi all,
Strange problem here: I have a laptop with 2 disks in it, 1T and 2T in size. I want to migrate my users and data from the 1T disk to the 2T disk. Therefore i did a fresh install F32 on the 2T one and migrated all what i wanted. So far so good.

Strange thing however is while i have exactly the same configuration in grub2 and everything else seems exactly the same, one small irritating issue occurs : the tty’s 1-6 and and boot terminal (the one after hitting ‘esc’ at graphical boot) have very large fonts: the monitor resolution is too low.
According to grub It should be 1920x1080. The 1T disk install does have the wanted resolution. This is a disk with Fedora upgrades from at least F24. I can’t discover the difference in configs/programms causing this problem. Console-setup doesnt do the trick.

What do i miss?

ps: Posting config files or /etc/default/grub etc isn’t very useful because the are exactly the same, as the harware of course

When booting, Grub cannot exactly use /etc/default/grub; instead it uses a copy that it made in a more convenient location. There is an obscure grub command to make that copy. Maybe it needs doing again?

Ty pbwolf, for your answere, but after every change in /etc/default/grub i run ’ # grub2-mkconfig -o /boot/grub2/grub.cfg’ (i know, i shouldn’t work as root, but a bit old skool here), what generates the appropriate grub.cfg file on the appropriate place. Every update works fine, except those tty’s…

Only difference in configurations of both disks is the partition type. The ‘good’ tty’s are in a LMV volume, the ‘bad’ tty’s are on ext4 volume. Can’t see why that should be a problem. It is a kernelopt thingie, should be getting settings from grub and initramfs. Maybe i should set tty’s in non graphic mode and generate a new initramfs? If so, how?
Only info i can find is setting console fonts and fontsize, nothing about setting tty resolutions (that works, what i do find is obsolete info).

Are you using Fedora? Are you using UEFI?
If the answer is yes to both then the output path for that is wrong. It should be grub2-mkconfig -o /boot/efi/EFI/fedora/grub.cfg . The path you gave would be correct for MBR (AKA legacy) boot on fedora.

I am using Fedora and BIOS, so path is ok.

The weird part is that i have a dual boot with one installation Fedora 32 (on 1TB disk) working fine (that is with a console resolution of 1920x1080) and one Fedora 32 (on 2TB disk) that is not (very low resolution), with exactly the same grub config files and methodes to apply them, on the same laptop. All parameters are ok (otherwise the good resolution tty’s would not be there on that one installation). So why do i have that unwanted console (tty) resolution on the 2TB disk? It is not a malconfigured grub issue, somehow the kernel (or the initramfs?) doesn’t have had the right parameters parsed? If so, how to do so?

Last cry for help on this one. When i do # grep gfx /boot/grub2/grub.cfg, the outcome is:

set gfxmode=1920x1080
  insmod gfxterm
terminal_output gfxterm
	set gfxpayload=keep
	set gfxpayload=keep
	set gfxpayload=keep

So all is set well. Anyone can give me a hint why the console resolution doesnt stick at 1920x1080 when leaving Grub and booting into Fedora?

[quote=“nippur, post:5, topic:10221, full:true”]
I am using Fedora and BIOS, so path is ok.

The weird part is that i have a dual boot with one installation Fedora 32 (on 1TB disk) working fine (that is with a console resolution of 1920x1080) and one Fedora 32 (on 2TB disk) that is not (very low resolution), with exactly the same grub config files and methodes to apply them, on the same laptop.[/quote]

Those statements may point to the problem. Fedora 32 is 64 bit only. BIOS implies using MBR partitioning instead of GPT. I do not know if a 2TB drive can be properly handled on a system using BIOS and that is MBR partitioned versus using UEFI and GPT partitioned drives, so that might lead to differences in the config and displays during boot and use of TTYs.

Those statements may point to the problem. Fedora 32 is 64 bit only. BIOS implies using MBR partitioning instead of GPT.

Only thing is…both Fedora 32 disks run fine on all other programms, i just don’t have a nice resolution at tty’s on one of them… So this can’t be it