Home Assistant broken?

Home assistant cli is broken package, because missing python 3? Can someone confirm this? Or it is python problem?
Output: UNTITLED - Pastebin Service

TIA

Could you please re-run the command with LANG=C dnf ... just to get the output in English for the benefit of forum users? If the output is short enough, it’s worth pasting it here in the forum itself because pastebin links tend to expire.

[zoltanh721@armyofpenguines ~]$ sudo LANG=C dnf install home-assistant-cli | fpaste
[sudo] zoltanh721 jelszava: 
Error: 
 Problem: conflicting requests
  - nothing provides (python3.10dist(netdisco) < 3 with python3.10dist(netdisco) >= 2.8.3) needed by home-assistant-cli-0.9.4-1.fc35.noarch

Yeh, it is currently FTI (fails to install). Two bugs filed:

https://bugzilla.redhat.com/buglist.cgi?bug_status=NEW&bug_status=ASSIGNED&bug_status=REOPENED&component=home-assistant-cli&list_id=12532126&product=Fedora&query_format=advanced

In the meantime, you can probably install it using pip in a virtualenv from pypi with something like:

python3 -m venv .venv
source .venv/bin/activate
pip install homeassistant-cli
1 Like

It has been successfully downloaded, installed, and upgraded as suggested the pip package to newer. How will I run the app?

You’ll have to refer to the homeassistant documentation for that. Presumably, there should be some homeassistant related command (cli) that you should be able to run.

They have their own discussion forum:

and their own documentation: