[hostapd] Host AP / 5Ghz Frequencies, no IR issues

The device appears to be operating normally.

# lspci | grep -i "ath"
04:00.0 Network controller: Qualcomm Atheros QCA9377 802.11ac Wireless Network Adapter (rev 31)

# iw list
Wiphy phy0
{…}
Band 1:
{…}
Band 2:
Frequencies:
5180 MHz [36] (30.0 dBm) (no IR)
{…}
5845 MHz [169] (30.0 dBm) (no IR)

Band 1(2.4Ghz) can be configured on Host AP without any special issues, but Band 2(5Ghz) cannot be configured because all bands are marked with no IR. So I just ignored it and ran it and the error appears as below.

# cat /etc/hostapd/hostapd.conf
ctrl_interface=/var/run/hostapd
ctrl_interface_group=wheel
driver=nl80211
macaddr_acl=0
auth_algs=1
ignore_broadcast_ssid=0
ieee80211h=0
ieee80211ac=1
ieee80211d=1
country_code=00
interface=wlp4s0
bridge=br0
hw_mode=a
channel=44
ssid=AP
wpa=3
wpa_key_mgmt=WPA-PSK
wpa_pairwise=TKIP
rsn_pairwise=CCMP
wpa_passphrase=00000000

# journalctl -xeu hostapd
– The job identifier is 17319.
Jun 30 00:42:50 localhost hostapd[11407]: Configuration file: /etc/hostapd/hostapd.conf
Jun 30 00:42:50 localhost hostapd[11407]: wlp4s0: interface state UNINITIALIZED->COUNTRY_UPDATE
Jun 30 00:42:50 localhost hostapd[11407]: Channel 44 (primary) not allowed for AP mode, flags: 0x2073 NO-IR
Jun 30 00:42:50 localhost hostapd[11407]: wlp4s0: IEEE 802.11 Configured channel (44) not found from the channel list of current mode (2) IEEE 802.11a
Jun 30 00:42:50 localhost hostapd[11407]: wlp4s0: IEEE 802.11 Hardware does not support configured channel
Jun 30 00:42:50 localhost hostapd[11407]: Could not select hw_mode and channel. (-3)
Jun 30 00:42:50 localhost hostapd[11407]: wlp4s0: interface state COUNTRY_UPDATE->DISABLED
Jun 30 00:42:50 localhost hostapd[11407]: wlp4s0: AP-DISABLED
Jun 30 00:42:50 localhost hostapd[11407]: wlp4s0: Unable to setup interface.
Jun 30 00:42:50 localhost hostapd[11407]: wlp4s0: interface state DISABLED->DISABLED
Jun 30 00:42:50 localhost hostapd[11407]: wlp4s0: AP-DISABLED
Jun 30 00:42:50 localhost hostapd[11407]: wlp4s0: CTRL-EVENT-TERMINATING
Jun 30 00:42:50 localhost hostapd[11407]: hostapd_free_hapd_data: Interface wlp4s0 wasn’t started
Jun 30 00:42:50 localhost hostapd[11407]: nl80211: deinit ifname=wlp4s0 disabled_11b_rates=0
Jun 30 00:42:50 localhost hostapd[11407]: wlp4s0: IEEE 802.11 Configured channel (44) not found from the channel list of current mode (2) IEEE 802.11a
Jun 30 00:42:50 localhost hostapd[11407]: wlp4s0: IEEE 802.11 Hardware does not support configured channel
Jun 30 00:42:50 localhost systemd[1]: hostapd.service: Control process exited, code=exited, status=1/FAILURE

There was no such error for the tp-link router with the openwrt firmware currently in use.
In this case, is Band 2(5Ghz) not available?

Thanks.