How can I activate my AC-7260 interface?

Hello,

I have recently installed Fedora 36 on an old laptop Toshiba Satellite L550. No problem with the installation and Fedora is working fine. As I believed the original Wifi interface is too slow, I replaced it with an AC-7260. I wanted to install the driver (iwl7260-firmware.noarch) but Fedora told me it is already installed (Nothing to be done). And with “lspci” I can see : “07:00.0 Network controller: Intel Corporation Wireless 7260 (rev bb)”. And still I cannot activate the Wifi connection as the interface is unavailable. I clearly have missed some steps so can you tell me what I need to configure or install ?

Hello,

please show the output of:

lspci -k | grep -i -3 network

After that you can test yourself if the module was loaded:

lsmod | grep >your_modulnamex<

The output of:

rfkill

could also provide helpful infos.

1 Like

Thank you for your help.
These are the output for the suggested commands :

[black.cap17@FC-Satellite ~]$ lspci -k | grep -i -3 network
	Subsystem: Toshiba Corporation Device ff82
	Kernel driver in use: snd_hda_intel
	Kernel modules: snd_hda_intel
07:00.0 Network controller: Intel Corporation Wireless 7260 (rev bb)
	Subsystem: Intel Corporation Dual Band Wireless-AC 7260
	Kernel driver in use: iwlwifi
	Kernel modules: iwlwifi
[black.cap17@FC-Satellite ~]$ lsmod | grep iwlwifi
iwlwifi               413696  1 iwlmvm
iwlmei                 40960  2 iwlmvm,iwlwifi
cfg80211             1048576  4 iwlmvm,iwlmei,iwlwifi,mac80211
[black.cap17@FC-Satellite ~]$ rfkill
ID TYPE      DEVICE     SOFT     HARD
 0 bluetooth hci0   débloqué débloqué
 1 wlan      phy0   débloqué   bloqué
[black.cap17@FC-Satellite ~]$
1 Like

hi,
I’m not a moderator but I think that terminal inputs and outputs should be put in a code block to make it easier to read.
codeblock

Your card is hardware blocked.
What happens if you enter the following as root (sudo or su):

modprobe iwlwifi

After that we can look at the kernel messages:

dmesg | grep  iwlwifi

EDIT: #>modprobe< corrected

Your wifi interface shows iwlwifi module in use.
The hardware shows as hard blocked with the rfkill command.

Is this machine dual booting with windows by chance? If it is, and if within windows you have disabled wifi, then some machines will hard block the interface in linux and fedora cannot unblock it.

Try sudo rfkill unblock wlan followed by rfkill list wlan to see the status again.

If it fails to unblock the device then try the fix with booting into windows and activating wifi before you shutdown windows and restart fedora.

1 Like

Thank you all for your help.
My computer is not a dual-boot machine . I only have Fedora 36 on it, no Windows partition.
As you see, I could not unblock wlan with rfkill. This is what the commands you suggested have returned :

saisissez [black.cap17@FC-Satellite ~]$ modprobe iwlwifi
[black.cap17@FC-Satellite ~]$ 
[black.cap17@FC-Satellite ~]$ dmesg | grep  iwlwifi
[   23.559820] iwlwifi 0000:07:00.0: loaded firmware version 17.3216344376.0 7260-17.ucode op_mode iwlmvm
[   24.023668] iwlwifi 0000:07:00.0: Detected Intel(R) Dual Band Wireless AC 7260, REV=0x144
[   24.029946] iwlwifi 0000:07:00.0: reporting RF_KILL (radio disabled)
[   24.029984] iwlwifi 0000:07:00.0: RF_KILL bit toggled to disable radio.
[   24.043435] iwlwifi 0000:07:00.0: base HW address: 00:16:6f:f9:62:c1, OTP minor version: 0x0
[   24.075494] iwlwifi 0000:07:00.0 wlp7s0: renamed from wlan0
[black.cap17@FC-Satellite ~]$ sudo rfkill unblock wlan
[sudo] Mot de passe de black.cap17 : 
[black.cap17@FC-Satellite ~]$ sudo rfkill list wlan
1: phy0: Wireless LAN
	Soft blocked: no
	Hard blocked: yes
[black.cap17@FC-Satellite ~]$ 

I have no further suggestions, but it is clear that as long as the interface is hard blocked it will not work.

If your laptop has a physical switch to enable/disable the wifi that may be the cause (the manual does not indicate a wifi physical switch that I can find). If it previously had windows installed and the wifi was disabled that also may be the cause, in which case the only fix may be to reinstall windows, enable the wifi, then switch back to linux.

The interface is getting configured as you can see by the dmesg output, it is just disabled.

Maybe someone else has another suggestion for this.

I can’t think of much else to say now except;

Try this:

sudo rfkill unblock all

Is that a Toshiba Satellite laptop? (I read that name in your terminal output).
These often have a key combination to activate the WLan.
Mostly FN+WLAN. Please check once. In case of need search the internet for your device.

From this point of view it can also help in an absolute emergency to reset the Bios/Uefi (set to default).

Is this a used device?

Thank you all for your help and suggestions. I have tried all the suggested commands without success. So my Toshiba Satellite laptop must have some incompatibility with the AC-7260 interface. I have reinstalled the original Wifi card, which is a Realtek RTL8192SE . It’s not very fast but at least it’s not blocked.