How do I forcibly unlock gnome-shell on wayland?

I reported a problem back with Fedora29 where gnome-shell on wayland would seem to double-lock the screen, that is, I got the typical gnome-shell lock screen, but upon entering the password, the lock screen would slide up, only to reveal another lock screen with minor differences–the top desktop bar “[Activities] [<current window title] … [date/time] … [icon tray]” would display as if the screen were unlocked, but everything below still appeared as the lock screen.

Sometimes I would be able to enter things into the password prompt (a second time), and other times it would be difficult to place focus on the text field. I would be able to perform somewhat limited, bind manipulations of the active desktop windows-- hotkeys like Ctrl-W would seem to work on a running browser, but the only visual feedback I could get is from the top-screen status bar. For example, I could know that I successfully closed an application when no amount of Alt-Tab activity brought the window title to the top status bar.

I reported the bug originally with a perhaps unrelated title on fedora 29, and still encounter it in fedora 31. I had no idea what triggered it, so I used the nearest abrt entry: https://bugzilla.redhat.com/show_bug.cgi?id=1702504

I am able to switch console terminals (e.g., by Ctrl-Alt-F3) and use the console there. loginctl unlock-session ID has no effect and loginctl unlock-sessions has no effect. My only recourse seems to be loginctl kill-session ID, or reboot, both of which cause an undesirable loss of application state, but are better than never having another desktop session on my laptop.

At this point, I am mostly unoptimistic about an actual fix to the problem (but would ABSOLUTELY LOVE IT) as we are now two releases later with no fix in sight. Does anyone have other suggestions on how to recover the desktop? Is there another way to forcibly unlock the screen (dbus? other signal? process to kill?) so I don’t lose my state? gnome-shell over wayland doesn’t have the same restart-gnome-shell-but-keep-state ability the way it had on X11(?).
Here’s a screenshot:

I’m not sure I can answer your question, but I wonder if there’s a crash somewhere. Do you have any extensions enabled?

1 Like

Right now, I do. I don’t think they are the problem though, because I tried dropping all of them for a month or so, and the problem didn’t go away, so I figured I might as well enjoy life with extensions if my desktop locks me out anyway.

I have never seen this error. As you describe it, it seems like a configuration error. Is it possibly linked to your userid? You could create a new, fresh user to find out. If it is not user, then it has to be system configuration, which begs the question how you upgraded: fresh install, or upgrade.

I too am not sure I can help you further, but this might give you (and some experts out there) more information on what might be wrong.

1 Like

The first step here would be to create a fresh new user and see if the bug persists there. If it does, it’s a system issue, otherwise it’s specific to your user configuration. Once we’ve narrowed the issue down, we can look further into what maybe causing it.