How do I remove the alsa driver from pulseaudio

I am wondering how I can remove the alsa driver from the pulseaudio so I can use just pulseaudio for my sound without the alsa driver attached. I want to be able to use the pulseaudio icons for the configuration and other settings in pulseaudio.
Alsa seems ok, but there is more control of configurations in pulseaudio for sound through HDMI and such. Thanks for any help.

I am not sure what you mean. ALSA is the sound system in the kernel, and PulseAudio is a user-space wrapper around it. If you remove ALSA, you can’t use PulseAudio.

4 Likes

I’d say that PulseAudio is more (maybe much more) than the wrapper around ALSA, but I second @QuLogic’s main idea: you won’t be able to use your audio devices without ALSA.

Also keep in mind that ALSA and PulseAudio control (and let you configure) different parts of your sound system. It’s perfectly fine not to use ALSA’s configuration tools if you don’t need them.

Still there’re some sound problems that can’t be solved with just PA’s controls (again, different parts). In such a case you’ll have to use, for example, alsamixer (and other ALSA tools/controls).

Then why is it I can’t find the pulseaudio icon on my system to click on it for the configuration.

By default PulseAudio’s settings configured through Gnome’s Settings’ --> Sound control panel. This one got simplified a couple of Gnome’s releases back – so some settings that can be useful got removed. )) Maybe we should add here that for most users and in simple cases the setting presented there should be enough.

Mostly they’re enough for me too – and when I need some more control, I usually use Pulse Audio Volume Control – or pavucontrol. You can install it through Software or with dnf:

sudo dnf install pavucontrol
1 Like

@wheelie207 I agree @QuLogic 's opionion. it’s a need to use for sound system.

1 Like

Then I’ll have to rip sound control out of gnome so I can control the configuration in pulseaudio or I’ll change to another distro that doesn’t control the sound and a couple other things.
It’s getting so that gnome limits control which is as bad as windows.

@wheelie207, I don’t think you need to rip anything. Yes, gnome has only basic sound controls – but on the other hand it doesn’t prohibit you the use of more advanced tools – like pavucontrol for PulseAudio or alsamixer for ALSA – and it doesn’t override the changes you make through these tools. I personally find that quite a good compromise.

On the other hand one of the strongest points of Linux is the freedom of choice. Everyone can choose distro or desktop environment to his liking, the tools for things he needs done, etc. The reverse of this power is ability to easily break things, of course)

People tend to praise KDE for it’s abundance of controls and settings for everything. I’ve used it for some time in the past, it was ok for me – now I use gnome – and it’s comfortable for me too.


Maybe if you tell here, what exactly you’re trying to solve – someone can give use some suggestions and tell what other tools you might need.

For just the control of PulseAudio please try pavucontrol as suggested above.

Pulseaudio has the ability to send sound over HDMI which is what I want to do. But gnome doesn’t see that when setting up sound on my setup. Gnome only see’s what that computer hardware has and nothing else outside of my linux box.
People tell me to use the volume control for it, but I have to change configuration in pulseaudio.

I think this is actually how it should be. It should see the actual physical outputs of your Linux box, not something else.

That is, of course, if by

you mean actually plugging something like TV or monitor with built-in speakers into HDMI output on your Linux box and hearing sound from the speakers of that thing – and not something completely different, – like sending sound through network (PulseAudio can do this too) – that would be a totally different topic.


@wheelie207, first of all I’ve never used sound through HDMI – have no such devices, – so I can provide only general / limited help. For help from someone actually using HDMI sound I’d suggest to create a new topic with subject like “How to output sound through HDMI” or “I can’t output sound through HDMI”.


If you want to output sound through physical HDMI connector on your Linux box – then you need to choose HDMI output as the active one, make sure it isn’t muted and it’s volume is up. After that it’s up to something on the other end of HDMI cable (usually monitor with built-in speakers or at least with headphones output – or TV, if you have one plugged through HDMI) to actually play the sound to you.

So the things for you to check are:

  1. ALSA should see the HDMI output you will be using (as we’ve talked above, ALSA makes hardware work, PA just “routes” sound through various ALSA sound devices).

    We can use aplay --list-devices in the terminal for this. This is the output from my machine (a bit shortened for clarity):

    card 0: PCH [HDA Intel PCH], device 0: ALC887-VD Analog [ALC887-VD Analog]
    card 0: PCH [HDA Intel PCH], device 1: ALC887-VD Digital [ALC887-VD Digital]
    card 0: PCH [HDA Intel PCH], device 3: HDMI 0 [HDMI 0]
    card 0: PCH [HDA Intel PCH], device 7: HDMI 1 [HDMI 1]
    card 0: PCH [HDA Intel PCH], device 8: HDMI 2 [HDMI 2]
    card 0: PCH [HDA Intel PCH], device 9: HDMI 3 [HDMI 3]
    card 0: PCH [HDA Intel PCH], device 10: HDMI 4 [HDMI 4]
    card 1: NVidia [HDA NVidia], device 3: HDMI 0 [HDMI 0]
    card 1: NVidia [HDA NVidia], device 7: HDMI 1 [HDMI 1]
    

    If the output you want to use is not in this list – then PulseAudio won’t be able to help you – as far as I know. It’s a kernel and / or ALSA issue, this can be the case for quite new hardware which lacks proper support in kernel / ALSA. Hope it’s not the case for you )

    As you can see, in my case it lists analog and digital (i.e. SPDIF) output of my built-in audiocard (ALSA calls it HDA Intel PCH), then 5 HDMI outputs (!!!) from the same card. My motherboard has just one HDMI connector, I’m not sure what these other ones are. I think this is beside the point right now – although it can be a source of some confusion potentially.

    Also the list contains two HDMI connectors on an NVidia GPU (in practice I have one HDMI and one DVI there. AFAIK DVI now can output sound too, and that’s what ALSA sees as second HDMI).

  2. Check the configuration in pavucontrol.

    Again, here’s mine:

    As you can see, here we see the same two hardware devices (built-in audio and NVidia’s GPU shown as GP108). I have GP108 turned off as I don’t use it, and built-in one set to Analog stereo duplex – meaning I use analog connectors and both output and input (thus duplex).

    The choices available for GP108 are:

    Basically, that’s the same two HDMI outputs ALSA showed us, and each of them can de used in stereo, 5.1 or 7.1 mode. Also take note of (unplugged) (unavailable) next to each of the choices – ALSA or PulseAudio sees I have nothing connected to these outputs.

    There’re far more choices for built-in audio, but the principle is the same: for each of the outputs we’ve seen in ALSA it has multiple choices with different audio modes – and with or without input enabled.

    Basically, if you want to output audio through HDMI connector on your GPU – I’d set built-in audio to Disabled, then tested HDMI1 and HDMI2 of GP108 (in my example) as stereo until I hear sound. Or – hopefully – when you have something capable of playing audio actually connected to HDMI port – the right one won’t have (unplugged) (unavailable) next to it and you’ll know which one to use without guessing.

    If you want to use HDMI connector of built-in audio – same goes there. Choose the right profile in this dialog (or test all the available HDMI outputs if unsure).

  3. You need to make sure something is actually playing sound – because output of the application can be muted or volume set too low too. You can check it on Playback tab:

    VLC is playing right now, underneath the application’s name is it’s own volume control (different for each application) and output meter showing current output. Also to the right of the name is the mute button.

  4. Now go to Output Devices tab:

    Here we can see output devices currently active (i.e. not set to disabled in Configuration tab), currently active output of the device (again, chosen in Configuration tab), control volume of the output, and check sound meter below volume control.

    Again, note mute button to the right of the device name.

    In my case I’ve chosen HDMI output of my built-in audio card – and again, PA tells me there’s nothing plugged into it. Still I can set it as active device, set it’s volume and see that sound meter jumps right and left as sound gets output to this HDMI interface.

    One more thing to note is checkboxes under Advanced. As far as I can see that’s different encodings (as HDMI is a digital interface). There’s a chance the device you have plugged in your HDMI connector has to understand the encoding chosen here. I have no actual experience with sound through HDMI so that’s just a guess.


Please post here the output of aplay --list-devices on your machine and a screenshot of your Configuration tab of pavucontrol application, we can start from there. Or make a new topic as I’ve suggested above – and post them there (and give a link to new topic here).