How is the secure way to run "dnf upgrade --enablerepo=updates-testing" to check is the issue about a software is resolved

I filed a bug about blender and nouveau in bugzilla red hat, the problem is when you want to run blender , nouveau crash and blender can’t run.
The problem is fixed using xorg-x11-drv-nvidia-390xx nvidia drivers from rpmfusion.
Currenlty i am using xorg-x11-drv-nvidia-390xx and not nouveau.

https://bugzilla.redhat.com/show_bug.cgi?id=1964069

Now there is an “update” in updates-testing repository.

They ask me to run the following command

sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2021-95e340dc3d

And check if the issue gets resolved

I am in the same pc , is my only work pc, and for the moment i don’t want to reinstall the system in the worst case.

Any suggestion about the secure way to proceed.
Is there a way to go back, after that?

2 Likes

You might be interested in the “if you aren’t using snapper” section of the following post.

I haven’t tried the above personally, but Chris states that he does it frequently in the post.

1 Like

That update is safe to install, it’s already been pushed to stable repository (and doesn’t touch system components), so you can just install it with dnf update.
https://bodhi.fedoraproject.org/updates/FEDORA-2021-95e340dc3d

To check whether it fixed issue with nouveau, you’ll have to remove nvidia driver following RPMFusion howto instructions, reboot and run blender.

Removing nvidia blob should be safe and straightforward, but having a backup (or snapshot) is always smart - especially for mission critical computer.

2 Likes

Community can see this for more information on How to test updates

https://fedoraproject.org/wiki/QA:Updates_Testing

ok I was confused , thought that the command means and upgrade of all the system.
Thinks the advisory flag

--advisory=FEDORA-2021-d2964a512a

indicate the packages that needs to be updates.

1 Like

alternatively, you can run sudo dnf update --enablerepo=updates-testing blender, and only blender or whatever package you specify is being updated to the version available in updates-testing.

1 Like