How to check if firmware package is needed?

My Fedora 32 installation has various packages named *firmware*:

[tim@passepartout ~]$ rpm -qa \*firmware\*
iwl7260-firmware-25.30.13.0-119.fc32.noarch
iwl6000g2a-firmware-18.168.6.1-119.fc32.noarch
atmel-firmware-1.3-22.fc32.noarch
iwl135-firmware-18.168.6.1-119.fc32.noarch
iwl5000-firmware-8.83.5.1_1-119.fc32.noarch
ipw2200-firmware-3.1-19.fc32.noarch
iwl2030-firmware-18.168.6.1-119.fc32.noarch
iwl105-firmware-18.168.6.1-119.fc32.noarch
iwl6000-firmware-9.221.4.1-119.fc32.noarch
iwl4965-firmware-228.61.2.24-119.fc32.noarch
linux-firmware-20210315-119.fc32.noarch
iwl6050-firmware-41.28.5.1-119.fc32.noarch
iwl3945-firmware-15.32.2.9-119.fc32.noarch
iwl2000-firmware-18.168.6.1-119.fc32.noarch
iwl6000g2b-firmware-18.168.6.1-119.fc32.noarch
iwl5150-firmware-8.24.2.2-119.fc32.noarch
ipw2100-firmware-1.3-26.fc32.noarch
libertas-usb8388-firmware-20210315-119.fc32.noarch
alsa-sof-firmware-1.5-1.fc32.noarch
linux-firmware-whence-20210315-119.fc32.noarch
iwl1000-firmware-39.31.5.1-119.fc32.noarch
zd1211-firmware-1.5-6.fc32.noarch
iwl100-firmware-39.31.5.1-119.fc32.noarch
iwl3160-firmware-25.30.13.0-119.fc32.noarch
[tim@passepartout ~]$

I assume not all packages are needed for my hardware. How do I determine which firmware packages are actually in use and which ones can be safely uninstalled?

1 Like

The packages are fairly small, except for linux-firmware (which you need and don’t want to remove).
I think it’s not worthy risking a failing wifi for a few MB of freed disk space.

That’s why I have not uninstalled them yet (though they not only require disk space, but also network data & Co.); but whether they are needed or not should not be a game of chicken. For example, iwl100-firmware's summary reads “Firmware for Intel(R) Wireless WiFi Link 100 Series Adapters”. How can I reliably determine if my system uses a “Intel(R) Wireless WiFi Link 100 Series Adapter”? How does the kernel (?) determine if it needs the firmware file?

For example, lspci shows 02:00.0 Network controller: Intel Corporation Centrino Advanced-N 6235 (rev 24) for my Wi-Fi card. Then in the website I have linked below, it says that my card uses iwlwifi-6000g2b-ucode-..., I have installed iwl6000g2b-firmware package in Fedora and my Wi-Fi card works. For other firmware packages, I have only linux-firmware and linux-firmware-whence installed.

https://wireless.wiki.kernel.org/en/users/drivers/iwlwifi

2 Likes