How to disable "[App] is not responding" popup on gnome?

I want to disable the popup because it likes to keep showing itself on apps that are very clearly responding and its getting frustrating.

For quick solution (AFAIK)

Set timeout to 60 seconds from 5 seconds

# gsettings set org.gnome.mutter check-alive-timeout 60000

Set to 0 to disable completely

# gsettings set org.gnome.mutter check-alive-timeout 0

If app not responding or hang for certain reasons, since we don’t know more about It could be because of the app itself having some issues or It could be completely something else as well.

2 Likes