How to enable Cangjie (Traditional Chinese) input method in Fedora 34 i3 spin?

Just installed the i3 spin of Fedora Linux 34 to my test notebook.

How can I add Cangjie input method?

1 Like

Have you tried in a terminal to enter : /usr/bin/ibus-setup-cangjie cangjie

Thanks for the hints.

I run ibus-setup-cangjie cangue, which I can select version 3/5 etc.

Then I run ibus-daemon in a terminal, then the ibus icon is shown in the default bar (next to the network icon).

Click on it, I have options to switch between Cangie( 倉 ) and EN.

For once or twice, the icon will change to show 倉. But majority of time, it will just stick in the default keyboard icon.

And never once I can enter any Cangjie codes (any keys pressed always give me the corresponding English Character, no matter it is in urxvt or in Firefox)