How to enable graphical login

Hello.
I installed Fedora 31 (but that doesn’t matter, this question is valid also for :fedora: 30) using the netinstall ISO and the textual installation (just for fun). I installed Workstation stuff and so on.
My issue is that when the system boots the textual login appears. I can obviously log in, and using sudo systemctl start gdm the graphical login window appears.
I tried to enable the service with sudo systemctl enable gdm but after the reboot I find the textual console again.
Well, I know, it is a dumb question, but which service it is supposed to be enabled in order to start the display manager log in window after the system boot?

Hi @alciregi

i dont know if this will do diference but in the ArchWiki the command indicated to this , should be:
sudo systemctl enable gdm.service

https://wiki.archlinux.org/index.php/GDM#Starting

Note it is gdm.service in place of gdm I though i had a similar issue when i did enable fstrim.service with this.

Regards.

1 Like

Thank you for your answer.

No way. It doesn’t start at boot.
After all systemctl enable gdm.service isn’t the same as systemctl enable gdm?

1 Like

You need to change the default systemd target. To do this, execute the following command:
systemctl set-default graphical.target

Regards.

8 Likes

It did the trick. Thank you.

1 Like

Yes it is … i am dumb :slight_smile:

Well… that makes two of us. :smiley:

1 Like

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.