How to enable Integrated Graphics and disable Dedicated Graphics in feodra 34

Hello,
I recently installed Nvidia Graphics driver in my laptop but now i want to shift back to Integrated Intel Graphics driver because my laptop is making loud fan noise.

Any solution

First of all, find out the name of the graphics driver modules you are using:

00:01.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Kaveri [Radeon R7 Graphics] (prog-if 00 [VGA controller])
	Subsystem: Gigabyte Technology Co., Ltd Device d000
	Flags: bus master, fast devsel, latency 0, IRQ 46, IOMMU group 0
	Memory at c0000000 (64-bit, prefetchable) [size=256M]
	Memory at d0000000 (64-bit, prefetchable) [size=8M]
	I/O ports at f000 [size=256]
	Memory at feb00000 (32-bit, non-prefetchable) [size=256K]
	Expansion ROM at 000c0000 [disabled] [size=128K]
	Capabilities: <access denied>
	Kernel driver in use: radeon
	Kernel modules: radeon, amdgpu

This How do I prevent a kernel module from loading automatically? - Red Hat Customer Portal discuss the details.

I found this will be enough for me to not using radeon
Add the following to boot parameters:
rd.driver.blacklist=radeon modprobe.blacklist=radeon

1 Like

First off you need to know that the nvidia driver is actually the problem before you can point to it as the cause. You did not give us anything about the modules / drivers actually loaded nor info about the hardware involved. All we know is that you installed the nvidia drivers, but do not even know where you got them or how they were installed. All that would be needed info before we can help.

Posting the output of the command “inxi -Gxx” (in code tags please) will tell us the info about the graphics environment.
Your narrative will tell us more details about how you got to where you are.

Almost all systems with the dual graphics cards use the integrated graphics by default and only use the dedicated graphics card when explicitly requested. I would not point fingers at the nvidia driver until more testing is done.