how to enable network in initramfs?

I want to use clevis (network-bound disk encryption) for my encrypted root filesystem. That means I need an active network connection (DHCP) in initramfs. This worked fine for me in CentOS 8 but I just can’t get it working in Fedora 31 (fresh install).

The lights on my ethernet port just stay dark after the UEFI hands over control the kernel. Only after initramfs is done and systemd-networkd is started at regular boot the network comes up. (This is also consistent with what I am seeing in journald but I think the lights are a pretty good indicator on what happens.)

I just can’t get initramfs working with my network. I tried passing “rd.ip=dhcp” in my grub start line. Any ideas?

excerpts from journald:

# this is early boot/initramfs
…
kernel: libphy: r8169: probed
kernel: r8169 0000:03:00.0 eth0: RTL8168h/8111h, …, XID 541, IRQ 129
kernel: r8169 0000:03:00.0 eth0: jumbo features [frames: 9200 bytes, tx checksumming: ko]
systemd-udevd[483]: ethtool: autonegotiation is unset or enabled, the speed and duplex are not writable.
systemd-udevd[500]: Using default interface naming scheme 'v243'.
systemd-udevd[500]: ethtool: autonegotiation is unset or enabled, the speed and duplex are not writable.
kernel: r8169 0000:03:00.0 enp3s0: renamed from eth0
…
# initramfs is done, systemd-networkd kicks in here
kernel: r8169 0000:03:00.0 enp3s0: Link is Down
kernel: r8169 0000:03:00.0 enp3s0: Link is Up - 1Gbps/Full - flow control rx/tx
kernel: IPv6: ADDRCONF(NETDEV_CHANGE): enp3s0: link becomes ready