How to enable RPM Fusion NVIDIA driver from command line

Howto enable RPM Fusion for Fedora 32 - Nonfree - NVIDIA Driver fron line command?
Thanks

@dariolesca, Welcome to the Fedora Community.

If you’ve not had a chance yet, please look at the #start-here category. It has some very useful information on using the forum and tips on Fedora usage.

I would also like to encourage you to open a new thread since you are asking a new question. It should be answered separately.

Rpmfusion provides a guide on how to install the NVIDIA driver: https://rpmfusion.org/Howto/NVIDIA

1 Like

I have read this how to, especially the section:

The prerequisite is to have followed the Configuration page to have at least the RPM Fusion nonfree section available.

Into rpmfusion configuration it is not explained how to enable RPM Fusion for Fedora 32 - Nonfree - NVIDIA Driver but only how to enable rpmfusion repository.
There is not a specific repo for NVIDIA driver into rpmfusion but only a rpmfusion notfree repo.
Then the line command alternative to gnome-software (I do not have gnome-software and PackageKit) is:
sudo dnf install https://download1.rpmfusion.org/free/fedora/rpmfusion-free-release-$(rpm -E %fedora).noarch.rpm https://download1.rpmfusion.org/nonfree/fedora/rpmfusion-nonfree-release-$(rpm -E %fedora).noarch.rpm
Is this rigth?
Thanks
Dario

Well, you need to enable the repository to install packages from it. So these steps need to be followed in order.

Yes, that is correct.

Yes it is. That will install the two rpmfusion repositories for you. You then proceed with the instructions on the Nvidia page to complete the installation.

1 Like

This is correct, above command installs two rpm packages which enable the rpmfusion free and nonfree repositories. And yes, it is required to have those enabled before you install the nvidia driver packaged by rpmfusion.

1 Like

Ok, I will try and let us know

I suggest you report this command line to [Optimus] Setting the NVIDIA GPU as primary (RPMFusion in Fedora 32 Workstation) howto

Many Thanks to All

2 Likes

Sorry for the double answers, we may have answered simultaneously…

1 Like

Why us, why not you? :slight_smile:

Hi @dariolesca, any reason as to why you do not wish the use GNOME Software to enable the RPMFusion repositories? :sweat_smile:

2 Likes

If you are referring to the third party repository that’s included with Gnome-software, we should note that that’s limited to Nvidia drivers only. I.e., it does not provide the rest of the software provided by RPMFusion.

1 Like

Isn’t that the scope here @FranciscoD? NVIDIA repository for the NVIDIA stuff. Plus I think it also has the Non-free repository listed.

1 Like

I can? I didn’t know I could do it.
If is useful, I will do it

I do not want two cache of downloaded rpm packages (/var/cache/PackageKit and /var/cache/dnf)
I remove gnome-software and PackageKit, I use only manual dnf for update packages and fedora new version.

Ok, then, there is a line command to do only that?

Agreed. While it is not much of a nuisance but still avoiding caching would be better.

+1, but no, it will not have the “general” RPMFusion repositories pre-installed for users. That does not meet the third party repository requirement, which is that each software must have a specialised repository that does not contain other software (for obvious licencing and security reasons).

This repository was created especially for Gnome Software so that the workstation team could include a special “third party repository” for nvidia, which is why it isn’t listed in the rpmfusion documentation for general users. Most users use rpmfusion for multimedia codecs anyway, so they just install both the general repositories.

https://fedoraproject.org/wiki/Workstation/Third_Party_Software_Repositories

The repository files are provided by the fedora-workstation-repositories package, so you just need to install that (if it isn’t already on your system):

$ sudo dnf repoquery -l fedora-workstation-repositories
/etc/yum.repos.d/_copr_phracek-PyCharm.repo
/etc/yum.repos.d/google-chrome.repo
/etc/yum.repos.d/rpmfusion-nonfree-nvidia-driver.repo
/etc/yum.repos.d/rpmfusion-nonfree-steam.repo

The repositories will be disabled by default. So you need to enable them by changing enabled=false to enabled=true in the file (as you would do for any other repository).

The right command line to enable only RPM Fusion for Fedora 32 - Nonfree - NVIDIA Driver are these:

sudo dnf install fedora-workstation-repositories
sudo dnf config-manager --set-enable rpmfusion-nonfree-nvidia-driver

Take from https://fedoraproject.org/wiki/Workstation/Third_Party_Software_Repositories

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.