How to enable the hotkeys for fzf?

https://github.com/junegunn/fzf#using-linux-package-managers

Key bindings (CTRL-T / CTRL-R / ALT-C) and fuzzy auto-completion may not be enabled by default.

Refer to the package documentation for more information. (e.g. apt-cache show fzf)

I use the default Gnome shell and installed fzf from the Fedora repository.

1 Like

As it says, see the package documentation, /usr/share/doc/fzf/README.Fedora:

To enable shell key bindings, source the applicable script from
/usr/share/fzf/shell from your shell initialization. For example, use
/usr/share/fzf/shell/key-bindings.bash in ~/.bashrc for user-wide bash.

2 Likes

Here’s the snippet I have in my ~/.bashrc:

        # fzf on Fedora
        if [ -x "$(command -v fzf)"  ]
        then
            source /usr/share/fzf/shell/key-bindings.bash
        fi

1 Like