How to enable wayland

Hey

Been on xorg for a while but want to give wayland a bash again. Followed the howtos to enable xorg, but now I can’t get wayland back.

Any ideas ?

Thanks

Nar

1 Like

At the login screen, after clicking on your username, select the “gear” icon and select GNOME

Also see:

https://docs.fedoraproject.org/en-US/quick-docs/configuring-xorg-as-default-gnome-session/

1 Like

Hey

Thansk for the reply, did try to reverse that but does not work. Look at the bottom of that link, there is a “Note”:

“With the above changes applied, the option to set the GNOME session to use Wayland will actually be removed from the “gear icon” menu on the login screen.”

Thanks

Nar

Just revert the changes you made to /etc/gdm/custom.conf. Do you have a copy of your previous configuration or do you remember everything you changed?

Any way, just set

WaylandEnable=true

and remove

DefaultSession=gnome-xorg.desktop
1 Like

Got it like that… Still not working

Screenshot from 2021-09-20 11-01-33

If you’re using the nvidia drivers may want to double check what’s mentioned here https://ask.fedoraproject.org/t/x11-is-used-instead-of-wayland-xwayland-after-installing-nvidia-fedora-34/15858/3

3 Likes

Very good solution, worked for me too.
Maybe it could be recommended to not to directly edit
/usr/lib/udev/rules.d/61-gdm.rules
Just copy it to /etc, like this
cp -pv /usr/lib/udev/rules.d/61-gdm.rules /etc/udev/rules.d/
and then edit the file in
/etc/udev/rules.d/


vi /etc/udev/rules.d/61-gdm.rules


# disable Wayland on Hi1710 chipsets
ATTR{vendor}=="0x19e5", ATTR{device}=="0x1711", RUN+="/usr/libexec/gdm-runtime-config set daemon WaylandEnable false"
# disable Wayland when using the proprietary nvidia driver
# DRIVER=="nvidia", RUN+="/usr/libexec/gdm-runtime-config set daemon WaylandEnable false"
# disable Wayland if modesetting is disabled
IMPORT{cmdline}="nomodeset", RUN+="/usr/libexec/gdm-runtime-config set daemon WaylandEnable false"

Using the nvidia drivers has historically forced using xorg. Only recently has progress been made in getting the nvidia drivers to work with wayland and I don’t know the current status.

It seems likely that you have a choice.
nvidia driver with xorg
or
nouveau driver with wayland.

3 Likes

Tried all of the options, non is working. Maybe it is my hybrid card that is not playing nice.

Will do a clean install when 35 is gold

My Nvidia Card causes problems when awaking after sleeping using wayland.
Then all graphic elements are distorted on one or another way.

I use xorg, just sometimes I want to check if it is still the case or if something have become better.
Nothing changed up to now.

In my experience it is best to disable wayland completely because if the login screen is running under wayland, this usually means trouble even if logged in using a xorg session.

Try adding the kernel parameter nvidia-drm.modeset=1 in grub.