How to fix Unity Editor LibSSL problem?

Hello, I am trying to use Unity on Fedora.
When Unity Editor project is created and opened this error occurs:
image

No usable version of libssl was found

I tried installing libssl, but it does’t help.
OpenSSL is installed, but Unity Editor keeps throwing the libssl error.

Install devel package then try again

dnf install openssl-devel

I tried this command.
The output says:

Package openssl-devel-1:3.0.2-2.fc36.x86_64 is already installed.

Yes, as far I can see it is installed because I can use openssl command.
It is version OpenSSL 1.1.1c. But I still have the save error in Unity Editor.

So If you type “openssl version” you get version 1 ? That’s weird becaue that’s the version I have right now.

openssl version

OpenSSL 3.0.2 15

Strange that you seem to have version 3.
On fedora 35 I have this.

# openssl version
OpenSSL 1.1.1n  FIPS 15 Mar 2022

and on fedora 36 I see this

 # openssl version
OpenSSL 3.0.2 15 Mar 2022 (Library: OpenSSL 3.0.2 15 Mar 2022)

Apparently there was a big jump in versions with the upgrade to fedora 36 (beta).

It was expected

https://fedoraproject.org/wiki/Changes/OpenSSL3.0

Version 1 is now named to : “openssl1.1.x86_64” so you can install ver1 too.

1 Like