How to fix “wifi adapter not found” in fedora 32

I installed fedora 32 on my MacBook air, but couldn’t start the wifi as it shows no wifi adapter found. I tried using the rpm commands they are not working it shows “curl error (6) couldn’t resolve host name for https //mirrors.fedoraproject.org/metalink?repo=fedora-cisco-openh264” every time. how do I solve this?

Well, if the network doesn’t work, you can’t reach the Fedora servers.

Yeah so how do i solve the " no wifi adapter found" problem

What kind of wifi adapter are you using? Is it Broadcom? If it is have you tried installing the broadcom-wl driver from RPM Fusion?

And here is something if you haven’t tried

Its broadcom bcm4360 802.11ac.
And i tried the commands from your last message, it didn’t work

I have found this bug report (for Ubuntu)… really unsure if it is linked to your problem:
https://bugs.launchpad.net/ubuntu/+source/bcmwl/+bug/1574196

I guess I would begin to ask for “lspci -nnvk” and show us the info for your card… in part it would indicate if the device use the driver.

Well… I am not using Fedora right now, so I might not give the best advice I could…

The idea is that the wl driver could do better than the bcma driver you are using…
info from: https://wiki.debian.org/wl

But I think if you do “modinfo wl” you might find it is not installed by default. So you might have to activate RPMFusion non-free than “dnf install akmod-wl”, then reboot.

After that, you should be able to:

modprobe -r b44 b43 b43legacy ssb brcmsmac bcma

that would remove current bcma driver, then:

modprobe wl

What about the boot loading time? What does systemd-analyze blame say? There is a bug in F32 systemd and one of the collateral issues that I experienced was missing wifi and bluetooth adapters in gnome. There is a chance that it’s related, try to rename these files:

cd /usr/lib/udev/rules.d/
sudo mv 61-gdm.rules 61-gdm.rules.bkp
sudo mv 64-md-raid-assembly.rules 64-md-raid-assembly.rules.bkp
sudo mv 65-md-incremental.rules 65-md-incremental.rules.bkp

This is the guide I used to install wifi drivers on my rMBP mid 2014

1 Like