How to improve boot time on Fedora 31?

Hello,

I would like to ask how can I improve my boot time on Fedora 31 KDE?

My PCs specs.

Outputs (since I can only put two links per post I put the outputs together):

systemd-analyze, systemd-analyze blame, systemd-analyze critical-chain, journalctl -b 0

Thanks,
Armand

The critical piece of information is in the very first line:

1min 3.339s (loader)

I don’t know why it’s taking that long or what to do about it, but that’s where you have to look.

(firmware) + 1min 3.339s is pretty high. That’s typical for servers. The 6-7s in userspace is typical. It might still be possible to do better.

systemd-analyze plot > plot.svg

An easy but effective way is to disable units you do not need:
systemctl list-units

Have a look on the active units. All active units in the list are to be started by systemd on boot unless you have started them manually without enabling them. In practice, if you have not intentionally activated a unit in that list (for a reason) by yourself, it is one that starts on boot. Disable an unnecessary unit using:
systemctl disable [unitname]

Be careful with disabling units. Check first why a unit is active before disabling it.

Finally, I managed to figure it out. The extreme long boot time was caused by an fstab error (unfortunately I have not removed the entry of a non-used drive).

Now my boot time is around 42-45s which is a lot better than before. As I have heard in the latest FW update for my MB the manufacturer managed to fix the long waiting time for the FW (POST) so maybe it can go down with another 14s. Maybe I will try that.

Thanks again for all of your suggestions! :slight_smile:

1 Like