How to increase resolution during the boot process?

I have the correct resolution on the grub menu, 1920x1080 but as soon as the boot process enters the systemd domain the resolution becomes really low, to the point it’s hard to read boot messages.

I have a 1660 super with the rpm fusion driver and disk encryption (excluding /boot).

I’m pretty sure it’s installed in legacy bios mode, it doesn’t boot if the firmware is set to UEFI only. The fedora 37 KDE installation media wouldn’t show any video otherwise (something about nvidia drivers not being signed).

inxi

CPU: 6-core AMD Ryzen 5 3600 (-MT MCP-) speed/min/max: 2210/2200/4208 MHz
Kernel: 6.1.6-200.fc37.x86_64 x86_64 Up: 8m Mem: 4023.4/15920.7 MiB (25.3%)
Storage: 2.57 TiB (29.1% used) Procs: 401 Shell: Bash inxi: 3.3.24

/etc/default/grub

GRUB_TIMEOUT="5"
GRUB_DISTRIBUTOR="$(sed 's, release .*$,,g' /etc/system-release)"
GRUB_DEFAULT="saved"
GRUB_DISABLE_SUBMENU="true"

# GRUB_TERMINAL_OUTPUT="console"                                                                                                                                                                                                            
#GRUB_CMDLINE_LINUX="rd.driver.blacklist=nouveau modprobe.blacklist=nouveau nvidia-drm.modeset=1 rd.luks.uuid=luks-80efd388-8ef3-4ebb-937d-ee3bea8598c4 initcall_blacklist=simpledrm_platform_driver_init rd.driver.blacklist=nouveau modprobe.blacklist=nouveau nvidia-drm.modeset=1 rhgb quiet"                                                                                                                                                                                      
GRUB_DISABLE_RECOVERY="true"
GRUB_ENABLE_BLSCFG="true"

GRUB_CMDLINE_LINUX="rd.driver.blacklist=nouveau modprobe.blacklist=nouveau nvidia-drm.modeset=1 rd.luks.uuid=luks-80efd388-8ef3-4ebb-937d-ee3bea8598c4 initcall_blacklist=simpledrm_platform_driver_init rd.driver.blacklist=nouveau modprobe.blacklist=nouveau nvidia-drm.modeset=1 quiet"

# GRUB_TERMINAL_INPUT="console"                                                                                                                                                                                                             
GRUB_TERMINAL_OUTPUT="gfxterm"
GRUB_GFXMODE="1920x1080x32"
GRUB_GFXPAYLOAD_LINUX="keep"
sudo grub2-mkconfig -o /boot/efi/EFI/fedora/grub.cfg
sudo grub2-mkconfig -o /boot/grub2/grub.cfg

Do you mean it goes to ‘high’ resolution, so all the text gets much smaller, or that it goes to ‘low’ resolution and the text is very large?

To confirm that you are booting in legacy or uefi mode the command cat /sys/firmware/efi/efivars will tell you if it is booting efi mode. If it returns a message that it is a directory then you are in efi mode. Any other message would tell you it is legacy mode boot.

If you are booting in efi mode then the istructions on how to sign the nvidia modules are at
https://rpmfusion.org/Howto/Secure%20Boot?highlight=(\bCategoryHowto\b)
and on your system at /usr/share/doc/akmods/README.secureboot

What is not stated but necessary is that you would need also to do a removal of the installed akmod-nvidia package and the kmod-nvidia packages then do a reinstall of akmod-nvidia so the modules are rebuilt and signed this time.
sudo dnf remove '*nvidia* --exclude=nvidia-gpu-firmware
sudo dnf install akmod-nvidia xorg-x11-drv-nvidia-cuda

If you are not booting in efi mode then you may need to set the bios to have secure boot disabled since (I think) only in efi mode can you use mokutil to install your own key for the nvidia drivers.

The text is very large, after I type 3 characters for my password it goes offscreen and starts “repeating” the prompt on the next lines.

I can confirm It’s not UEFI, the EFI fat32 partition is not even on fstab.

I can already boot and use the nvidia driver, the system itself and the grub menu are at 1920x1080, it’s just the systemd boot messages that use a very low resolution.

I don’t have any of those lines in /etc/default/grub. I never have a problem in booting or logging in.

$ cat /etc/default/grub
GRUB_TIMEOUT=10
GRUB_DISTRIBUTOR="$(sed 's, release .*$,,g' /etc/system-release)"
GRUB_DEFAULT=saved
GRUB_DISABLE_SUBMENU=true
GRUB_TERMINAL_OUTPUT="console"
GRUB_CMDLINE_LINUX="rd.driver.blacklist=nouveau modprobe.blacklist=nouveau nvidia-drm.modeset=1 initcall_blacklist=simpledrm_platform_driver_init rd.lvm.lv=fedora/root rhgb quiet kvm.ignore_msrs=1"
GRUB_DISABLE_RECOVERY="true"
GRUB_ENABLE_BLSCFG=true

I have to ask: Are you referring to the luks password prompt or to the main user graphical password screen?

I don’t have any of those lines in /etc/default/grub. I never have a problem in booting or logging in.

I added those lines but they didn’t solve the problem. I can boot and log in, but the boot process is almost unreadable.

I have to ask: Are you referring to the luks password prompt or to the main user graphical password screen?

I’m referring to the luks password prompt and the systemd boot messages. The SDDM login screen looks fine.

Enter luks password for (root disk name): ***********
[ OK ] Starting NetworkManager
[ OK ] Starting Thing
etc

This is very low resolution and almost impossible to read.

I disabled the splash screen because it looked terrible and low resolution too. It was just a grey granular background with three “loading dots” in the center and an ugly luks password prompt.
I did so by removing rhgb from GRUB_CMDLINE_LINUX=.

This was all on a fresh install, it never had the pretty fedora splash screen with a black background and the blue logo.

EDIT: Here is a picture of what happens. When I install updates during boot the messages are completely unreadable. The luks password quickly goes off screen and the password prompt starts “repeating” for every keys stroke. (This picture shows almost the entire screen, 1920x1080 ~21")

I don’t know if will work, but you could try to add “video=1920x1080” to GRUB_CMDLINE_LINUX=.

Another entry that might work is “vga=ask”.

I don’t have nvidia hardware to test with, so it is all untested.

1 Like

Apparently nvidia doesn’t support KMS so the solution was to use vga=0x377 which in my case corresponds to 1920x1080x32. It’s worth noting that vga= accepts hex and decimal but the output of vga=ask is in hex and doesn’t include the 0x part. You have to a add 0x yourself.

I didn’t test video=1920x1080.

Sorry for the delay, I only had vim installed in my system and didn’t know how to exit it. Had to wait for a power outage.

Exiting vim? or exiting something else?
The man page for vim & vi indicates how to save, exit, etc. Entering :q! will exit without saving. :qw writes and exits. Many more key options.

1 Like

When you open vim you get

~                                                                                                                   
~                                                                                                                   
~                                                                                                                   
~                                                                                                                   
~                                                VIM - Vi IMproved                                                  
~                                                                                                                   
~                                                 version 9.0.1221                                                  
~                                             by Bram Moolenaar et al.                                              
~                                        Modified by <bugzilla@redhat.com>                                          
~                                   Vim is open source and freely distributable                                     
~                                                                                                                   
~                                          Help poor children in Uganda!                                            
~                                  type  :help iccf<Enter>       for information                                    
~                                                                                                                   
~                                  type  :q<Enter>               to exit                                            
~                                  type  :help<Enter>  or  <F1>  for on-line help                                   
~                                  type  :help version9<Enter>   for version info                                   
~                                                                                                                   
~                                                                                                                   
~                                                                                                                   
~                                                                                                                   
~                 
1 Like

!
I had never seen that.
I always open vim with the file name I intend to edit so had not seen the display screen.
My entry usually is like vim <filename>