How to install editors when I am using texlive iso

I am using fedora and I installed texlive from an iso file, not repositories. I then flagged out texlive from the dnf config file. However, when I try installing editors such as kile, gummi or lyx, I get the following error.

Problem: package gummi-0.6.6-16.fc37.x86_64 requires texlive-latex, but none of the providers can be installed
      - conflicting requests
      - package texlive-collection-latexrecommended-9:svn57862-59.fc37.noarch is filtered out by exclude filtering
      - package texlive-latex-9:20210325-52.fc37.noarch is filtered out by exclude filtering
    (try to add '--skip-broken' to skip uninstallable packages)

Is there a way of installing editors without pulling some texlive dependencies from the repositories?

1 Like

Hi @sirfmoyo , welcome to the community. Please take a look at the introductory posts in the #start-here category if you’ve not had a chance to do so yet.

It depends: if these texlive dependencies are “weak dependencies”, you can skip installing them as noted here:

https://docs.fedoraproject.org/en-US/packaging-guidelines/WeakDependencies/#_weak_dependencies

If they are “strong” dependencies, they need to be pulled in.

The gist here is that Fedora packages are packaged to work well with other Fedora packages—that’s sort of the function of the distro—to provide a well curated, well integrated set of software. They’re not really designed to work with user installed software.

Is there a reason you’re using texlive from an ISO by the way? Is the version in Fedora not new enough? There are a number of advantages of using texlive from the repositories. Take a look here:

https://docs.fedoraproject.org/en-US/neurofedora/latex/